summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNichlas Severinsen2023-03-20 15:32:01 +0100
committerNichlas Severinsen2023-03-20 15:32:01 +0100
commitda098bd977d0fbc0c5c3edb36d69ab7c20a8d8da (patch)
tree75ede4883de8747d99e54fa6f83692f2d22999a7
downloadaur-da098bd977d0fbc0c5c3edb36d69ab7c20a8d8da.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1588407659e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = shufflecake
+ pkgdesc = Shufflecake - Plausible deniability layer for Linux (Userland tool)
+ pkgver = v0.1
+ pkgrel = 1
+ url = https://shufflecake.net/
+ arch = any
+ license = GPLv3
+ makedepends = make
+ depends = dm-sflc-git-dkms
+ provides = shufflecake
+ conflicts = shufflecake
+ source = https://codeberg.org/shufflecake/shufflecake-userland/archive/v0.1.tar.gz
+ sha256sums = 471bdab0da3fc67d78b46373fc1a33d01b92cb5927d12818149a75b9992e3ebf
+
+pkgname = shufflecake
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efe5edaca731
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Nichlas Severinsen <ns@nsz.no>
+
+pkgname=shufflecake
+_gitname=$pkgname-userland
+pkgver=v0.1
+pkgrel=1
+pkgdesc="Shufflecake - Plausible deniability layer for Linux (Userland tool)"
+arch=("any")
+url="https://shufflecake.net/"
+license=("GPLv3")
+depends=("dm-sflc-git-dkms")
+makedepends=("make")
+provides=("$pkgname")
+conflicts=("$pkgname")
+source=("https://codeberg.org/shufflecake/$_gitname/archive/$pkgver.tar.gz")
+
+sha256sums=("471bdab0da3fc67d78b46373fc1a33d01b92cb5927d12818149a75b9992e3ebf")
+
+build() {
+ cd "${srcdir}/$_gitname"
+ # TODO: patch install in Makefile so that it uses install instead of cp
+ # This will break in the future, just remove the line then
+ make
+}
+
+package() {
+
+ cd "$srcdir/$_gitname"
+
+ mkdir -p "$pkgdir/usr/bin"
+
+ sed -e "s/cp/install -m 755/" \
+ -e "s|/usr/bin|\$\(DESTDIR\)/usr/bin|" \
+ -i "Makefile"
+
+ make install DESTDIR="$pkgdir"
+
+}