summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan MacDonald2017-03-31 18:06:40 +0100
committerDan MacDonald2017-03-31 18:06:40 +0100
commit639db0770524a99c4fe2d012c248f5be646c1da2 (patch)
tree513c1d5a9ee19421d25fcc661d2ddac73e87361e
downloadaur-639db0770524a99c4fe2d012c248f5be646c1da2.tar.gz
Initial commit of shufti PKGBUILD
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
2 files changed, 27 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..99da88d4b6b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = shufti
+ pkgdesc = shufti - the persistent image viewer
+ pkgver = 2.0
+ pkgrel = 1
+ arch = any
+ license = AGPL3
+ depends = python-pyqt5
+ source = git+https://github.com/danboid/shufti.git
+ md5sums = SKIP
+
+pkgname = shufti
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..021647182c88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,15 @@
+pkgname=shufti
+pkgver=2.0
+pkgrel=1
+pkgdesc="shufti - the persistent image viewer"
+arch=('any')
+license=('AGPL3')
+depends=('python-pyqt5')
+source=("git+https://github.com/danboid/shufti.git")
+md5sums=('SKIP')
+package() {
+ cd "$srcdir/$pkgname"
+ mv shufti.py shufti
+ chmod +x shufti
+ install -Dm 755 {,"${pkgdir}"/usr/bin/}shufti
+}