summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorF0xedb2019-08-12 21:58:20 +0200
committerF0xedb2019-08-12 21:58:20 +0200
commit8852a9df384b52b64e2940979d5caba59f415bc1 (patch)
tree13aae81ecb0cc9e9190c0e4362c09109effc018e
downloadaur-8852a9df384b52b64e2940979d5caba59f415bc1.tar.gz
Initial packagebuild
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c40123766660
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = shunit-git
+ pkgdesc = A basic unit testing framework for bash
+ pkgver = r31.6a774f4
+ pkgrel = 1
+ url = https://github.com/F0xedb/shUnit
+ arch = any
+ license = GPL
+ makedepends = git
+ source = git+https://github.com/F0xedb/shUnit.git
+ md5sums = SKIP
+
+pkgname = shunit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd167de74fb7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Tom Meyers tom@pbfp.team
+pkgname=shunit-git
+pkgver=r31.6a774f4
+pkgrel=1
+pkgdesc="A basic unit testing framework for bash"
+arch=(any)
+url="https://github.com/F0xedb/shUnit"
+_reponame="shUnit"
+license=('GPL')
+
+source=(
+"git+https://github.com/F0xedb/shUnit.git")
+md5sums=('SKIP')
+makedepends=('git')
+
+pkgver() {
+ cd "$srcdir/$_reponame"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+build() {
+ return 0;
+}
+
+package() {
+ cd "$srcdir/$_reponame"
+ install -Dm755 shunit "$pkgdir"/usr/bin/shunit
+ install -Dm644 assert.sh "$pkgdir"/usr/bin/assert.sh
+}