summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpatrick962020-03-29 19:57:37 +0200
committerpatrick962020-03-29 19:57:37 +0200
commit74acd9b4162ef4302b7486bfdc79baa8be6758fd (patch)
treef024d407e992b7f8ddcd5676555c6709a4260854
parentc6b52d2c7604499b87aea3ef0b255d7da091249b (diff)
downloadaur-74acd9b4162ef4302b7486bfdc79baa8be6758fd.tar.gz
Version 2.1.8
The check function needs to be adapted because the tests only pass on bash and some are otherwise running using the shell used to build the package. Ref: https://github.com/kward/shunit2/pull/130
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4540a9ed509..15f70a701540 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = shunit2
pkgdesc = xUnit based unit testing for Unix shell scripts
- pkgver = 2.1.7
+ pkgver = 2.1.8
pkgrel = 1
url = https://github.com/kward/shunit2/
arch = any
license = Apache
depends = bash
- source = https://github.com/kward/shunit2//archive/v2.1.7.tar.gz
- sha256sums = 41a103aa984bfdeea3fec426edb0b3dda19153a5ce448d4b4bbe52a85c4d7fee
+ source = https://github.com/kward/shunit2//archive/v2.1.8.tar.gz
+ sha256sums = b2fed28ba7282e4878640395284e43f08a029a6c27632df73267c8043c71b60c
pkgname = shunit2
diff --git a/PKGBUILD b/PKGBUILD
index d613f4e7bc89..40dc36bfac4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Johannes Dewender arch at JonnyJD dot net
# Contributor: Geoffrey Teale <g.teale@elsevier.com>
pkgname=shunit2
-pkgver=2.1.7
+pkgver=2.1.8
pkgrel=1
pkgdesc="xUnit based unit testing for Unix shell scripts"
url="https://github.com/kward/shunit2/"
@@ -10,14 +10,14 @@ arch=('any')
license=('Apache')
depends=('bash')
source=(${url}/archive/v${pkgver}.tar.gz)
-sha256sums=('41a103aa984bfdeea3fec426edb0b3dda19153a5ce448d4b4bbe52a85c4d7fee')
+sha256sums=('b2fed28ba7282e4878640395284e43f08a029a6c27632df73267c8043c71b60c')
-check() {
+check() {
cd ${srcdir}/$pkgname-$pkgver
- ./test_runner
+ SHELL=/usr/bin/bash bash ./test_runner
}
-package() {
+package() {
cd ${srcdir}/$pkgname-$pkgver
install -d ${pkgdir}/usr/share/doc/shunit2/examples
install -t ${pkgdir}/usr/share/doc/shunit2 ./doc/*