summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpatrick962020-02-10 17:06:33 +0100
committerpatrick962020-02-10 17:06:33 +0100
commitc6b52d2c7604499b87aea3ef0b255d7da091249b (patch)
treebb2f01ca2472e17708e6622f72e254d501f225df
parent2e4e1fe8c33e7219626cb4a3aa60e2b8b6ecf059 (diff)
downloadaur-c6b52d2c7604499b87aea3ef0b255d7da091249b.tar.gz
Version 2.1.7
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd743cd7fee4..d4540a9ed509 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
-# Generated by mksrcinfo v8
-# Sun Oct 16 16:33:47 UTC 2016
pkgbase = shunit2
pkgdesc = xUnit based unit testing for Unix shell scripts
- pkgver = 2.1.6
- pkgrel = 8
+ pkgver = 2.1.7
+ pkgrel = 1
url = https://github.com/kward/shunit2/
arch = any
- license = LGPL2.1
+ license = Apache
depends = bash
- source = https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/shunit2/shunit2-2.1.6.tgz
- md5sums = 4af955ef88c454808754939c83afa22b
+ source = https://github.com/kward/shunit2//archive/v2.1.7.tar.gz
+ sha256sums = 41a103aa984bfdeea3fec426edb0b3dda19153a5ce448d4b4bbe52a85c4d7fee
pkgname = shunit2
diff --git a/PKGBUILD b/PKGBUILD
index 4e300d390d20..d613f4e7bc89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
+# Maintainer: Patrick Ziegler p.ziegler96 at gmail dot comd
# Contributor: Johannes Dewender arch at JonnyJD dot net
# Contributor: Geoffrey Teale <g.teale@elsevier.com>
-pkgname=shunit2
-pkgver=2.1.6
-pkgrel=8
+pkgname=shunit2
+pkgver=2.1.7
+pkgrel=1
pkgdesc="xUnit based unit testing for Unix shell scripts"
url="https://github.com/kward/shunit2/"
arch=('any')
-license=('LGPL2.1')
+license=('Apache')
depends=('bash')
-source=(https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/$pkgname/$pkgname-$pkgver.tgz)
-md5sums=('4af955ef88c454808754939c83afa22b')
+source=(${url}/archive/v${pkgver}.tar.gz)
+sha256sums=('41a103aa984bfdeea3fec426edb0b3dda19153a5ce448d4b4bbe52a85c4d7fee')
check() {
cd ${srcdir}/$pkgname-$pkgver
- cd src && ./shunit2_test.sh
+ ./test_runner
}
package() {
@@ -22,5 +23,5 @@ package() {
install -t ${pkgdir}/usr/share/doc/shunit2 ./doc/*
install -t ${pkgdir}/usr/share/doc/shunit2/examples ./examples/*
- install -D src/shunit2 $pkgdir/usr/bin/shunit2
+ install -D shunit2 $pkgdir/usr/bin/shunit2
}