summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralexdiaconescu2016-01-30 23:06:15 +0200
committeralexdiaconescu2016-01-30 23:06:15 +0200
commita66c806247a8df9fce007510e178aed88d2e672b (patch)
treeac7403b0907360e700a98b6eeb230707716b7635
downloadaur-a66c806247a8df9fce007510e178aed88d2e672b.tar.gz
Initial import
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD55
-rw-r--r--shuriken.desktop10
-rw-r--r--shuriken.install11
-rw-r--r--shuriken.pngbin0 -> 5064 bytes
5 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e86a44d849f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+# Generated by mksrcinfo v8
+# Sat Jan 30 21:04:28 UTC 2016
+pkgbase = shuriken
+ pkgdesc = An open source beat slicer
+ pkgver = 0.5.1
+ pkgrel = 1
+ url = https://rock-hopper.github.io/shuriken
+ install = shuriken.install
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = automake
+ makedepends = libtool
+ makedepends = pkg-config
+ makedepends = jack
+ depends = qt4
+ depends = aubio
+ depends = rubberband
+ depends = libsamplerate
+ depends = libsndfile
+ depends = libx11
+ optdepends = jack: A low-latency audio server
+ source = https://github.com/rock-hopper/shuriken/archive/v0.5.1.tar.gz
+ source = shuriken.desktop
+ source = shuriken.png
+ sha256sums = 93175d0e992afebd05b476a78a6809894376a3e8ba4ea95ee3f5d9a67947db7d
+ sha256sums = f2144b34c35ecb855009a5d888d13bac2cf5b379274d7b60e4d9181d742fda99
+ sha256sums = b637b82c35bb4f27eebe779c7790a85758e1b9c64fff8553ede207dda0d9cb37
+
+pkgname = shuriken
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60be1c3b7941
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# $Id$
+# Contributor: Andrew M Taylor <a.m.taylor303 at gmail dot com>
+# Maintainer: Joermungand <joermungand at gmail dot com>
+
+pkgname=shuriken
+pkgver=0.5.1
+pkgrel=1
+pkgdesc="An open source beat slicer"
+url="https://rock-hopper.github.io/shuriken"
+arch=('x86_64' 'i686')
+license=('GPL')
+depends=('qt4' 'aubio' 'rubberband' 'libsamplerate' 'libsndfile' 'libx11')
+makedepends=('automake' 'libtool' 'pkg-config' 'jack')
+optdepends=('jack: A low-latency audio server')
+install="$pkgname.install"
+source=("https://github.com/rock-hopper/$pkgname/archive/v$pkgver.tar.gz"
+ "$pkgname.desktop"
+ "$pkgname.png")
+sha256sums=('93175d0e992afebd05b476a78a6809894376a3e8ba4ea95ee3f5d9a67947db7d'
+ 'f2144b34c35ecb855009a5d888d13bac2cf5b379274d7b60e4d9181d742fda99'
+ 'b637b82c35bb4f27eebe779c7790a85758e1b9c64fff8553ede207dda0d9cb37')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ # make sndlib
+
+ mkdir -p lib
+ cd src/SndLibShuriken
+ ./configure --without-audio --without-s7
+ make
+ mv -v libsndlib_shuriken.a ../../lib/
+ cd ../..
+
+ # make shuriken
+
+ declare _arch=""
+
+ if [[ $( lscpu | grep 'Architecture' ) =~ (x86_64) ]]; then
+ _arch="-64"
+ fi
+
+ qmake-qt4 PREFIX=/usr ./Shuriken.pro -r -spec linux-g++$_arch
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make INSTALL_ROOT="$pkgdir" install
+
+ install -Dm644 ../$pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+
+ install -Dm644 ../$pkgname.png "$pkgdir/usr/share/icons/$pkgname.png"
+}
diff --git a/shuriken.desktop b/shuriken.desktop
new file mode 100644
index 000000000000..623147ea60a3
--- /dev/null
+++ b/shuriken.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Name=Shuriken
+GenericName=Beat Slicer
+Comment=Shuriken Beat Slicer
+Exec=shuriken %F
+Icon=shuriken
+Terminal=false
+Type=Application
+Categories=AudioVideo;Audio;AudioEditing;
diff --git a/shuriken.install b/shuriken.install
new file mode 100644
index 000000000000..e111ef946053
--- /dev/null
+++ b/shuriken.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/shuriken.png b/shuriken.png
new file mode 100644
index 000000000000..d6449092d159
--- /dev/null
+++ b/shuriken.png
Binary files differ