summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShutSentry2022-12-18 11:28:21 -0500
committerShutSentry2022-12-18 11:28:21 -0500
commit6ad1d72b7fd7c64a0fe2784144c5873d3516cd94 (patch)
tree3cd686f3c3e456683dd519f827c378f94f2918f8
downloadaur-6ad1d72b7fd7c64a0fe2784144c5873d3516cd94.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8035adb2a646
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = shutsentry
+ pkgdesc = ShutSentry is a virtual dead-man-switch that protects computers from unauthorized physical access, by presenting an on-screen password-challenge prompt at regular time intervals, and/or reacting to other trigger events like USB/Bluetooth device changes.
+ pkgver = 2.5
+ pkgrel = 1
+ url = https://gitlab.com/shutsentry/shutsentry
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = make
+ depends = gtk3
+ provides = shutsentry
+ source = git+https://gitlab.com/shutsentry/shutsentry.git
+ md5sums = SKIP
+
+pkgname = shutsentry
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48679a12f167
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: ShutSentry <shutsentry@nospam.com>
+pkgname=shutsentry
+pkgver=2.5
+pkgrel=1
+pkgdesc="ShutSentry is a virtual dead-man-switch that protects computers from unauthorized physical access, by presenting an on-screen password-challenge prompt at regular time intervals, and/or reacting to other trigger events like USB/Bluetooth device changes."
+arch=(x86_64)
+url="https://gitlab.com/shutsentry/shutsentry"
+license=('GPL')
+depends=(gtk3)
+makedepends=(git make)
+optdepends=()
+provides=(shutsentry)
+source=('git+https://gitlab.com/shutsentry/shutsentry.git')
+md5sums=('SKIP')
+
+build() {
+ cd shutsentry
+
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+ mkdir -p "${pkgdir}/usr/share/applications"
+ install -m 755 shutsentry/Src/Linux/shutsentry "${pkgdir}/usr/bin"
+ install shutsentry/Src/Linux/shutsentry.desktop "${pkgdir}/usr/share/applications"
+}