summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex2019-11-25 22:04:42 +0100
committerAlex2019-11-25 22:04:42 +0100
commit580966f0da11dd1dbadfe6b9e7a70c8152d8ba71 (patch)
tree700b9b945bff3c43e45af128da32767470415559
downloadaur-580966f0da11dd1dbadfe6b9e7a70c8152d8ba71.tar.gz
First push
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..24ca585eb3af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = shuttlepro-v2-git
+ pkgdesc = A user program for interpreting input from a Contour Design Shuttle device (git version). This is a moded version from SERVCUBED. https://github.com/SERVCUBED/ShuttlePRO
+ pkgver = 0.1.r49.g2bb3c65
+ pkgrel = 1
+ url = https://github.com/SERVCUBED/ShuttlePRO
+ arch = x86_64
+ arch = i686
+ license = GPL
+ depends = libxtst
+ depends = jack
+ provides = shuttlepro
+ conflicts = shuttlepro
+ conflicts = shuttlepro-git
+ conflicts = contour-shuttle-git
+ source = shuttlepro-v2-git::git+https://github.com/SERVCUBED/ShuttlePRO.git
+ md5sums = SKIP
+
+pkgname = shuttlepro-v2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a241be11bb5d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Alex S. <shantanna_at_hotmail_dot_com>
+
+pkgname=shuttlepro-v2-git
+pkgver=0.1.r49.g2bb3c65
+pkgrel=1
+pkgdesc="A user program for interpreting input from a Contour Design Shuttle device (git version). This is a moded version from SERVCUBED. https://github.com/SERVCUBED/ShuttlePRO"
+arch=('x86_64' 'i686')
+# This is forked project from https://github.com/agraef/ShuttlePRO.
+url="https://github.com/SERVCUBED/ShuttlePRO"
+license=('GPL')
+depends=('libxtst' 'jack')
+provides=('shuttlepro')
+conflicts=('shuttlepro' 'shuttlepro-git' 'contour-shuttle-git')
+source=("$pkgname::git+https://github.com/SERVCUBED/ShuttlePRO.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make install prefix=/usr DESTDIR="$pkgdir"
+ install -d "$pkgdir/usr/share/doc/$pkgname"
+ install -m644 README.md LICENSE "$pkgdir/usr/share/doc/$pkgname"
+}