summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDidrole2020-08-06 14:31:25 +0200
committerDidrole2020-08-06 14:31:25 +0200
commit4e49f6c4c90961da2b03cf7305c185939ef2b252 (patch)
tree4ba177c6d89a1b807fe161fc4112b4b260ef99ca
parentb10ecb1679da59524fe162abbc8dfb206c5ab043 (diff)
downloadaur-4e49f6c4c90961da2b03cf7305c185939ef2b252.tar.gz
Rewrote of the PKGBUILD file.
This is now a split package which provides siac (the client) and siad (the server). The package will be built from the latest stable release instead of the master branch. The man files are now installed with siad.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD62
2 files changed, 45 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ac1ee40bf51..75559644c9da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,21 @@
pkgbase = sia
- pkgdesc = Blockchain-based marketplace for file storage
- pkgver = 20170103
+ pkgdesc = Decentralized storage for the post-cloud world
+ pkgver = 1.5.0
pkgrel = 1
url = https://sia.tech
- arch = i686
arch = x86_64
license = MIT
makedepends = git
makedepends = go
- makedepends = make
- source = git+https://github.com/NebulousLabs/Sia
+ conflicts = sia-daemon
+ source = git+https://gitlab.com/NebulousLabs/Sia.git#tag=v1.5.0
sha256sums = SKIP
+pkgname = siac
+ pkgdesc = Sia Client - Decentralized storage for the post-cloud world
+ optdepends = siad: sia daemon to interact with
+
pkgname = siad
+ pkgdesc = Sia Daemon - Decentralized storage for the post-cloud world
+ optdepends = siac: cli tool to manage a siad instance
diff --git a/PKGBUILD b/PKGBUILD
index b822ec1ce26e..d171df51a0be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,50 @@
-# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+# Maintainer: Didrole <Didrole@gmail.com>
+# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgbase=sia
-pkgname=('siad')
-pkgver=20170103
+pkgname=('siac' 'siad')
+pkgver=1.5.0
pkgrel=1
-pkgdesc="Blockchain-based marketplace for file storage"
-arch=('i686' 'x86_64')
-makedepends=('git' 'go' 'make')
-url="https://sia.tech"
+pkgdesc='Decentralized storage for the post-cloud world'
+arch=('x86_64')
+makedepends=('git' 'go')
+url='https://sia.tech'
license=('MIT')
-source=(git+https://github.com/NebulousLabs/Sia)
+conflicts=('sia-daemon')
+source=("git+https://gitlab.com/NebulousLabs/Sia.git#tag=v${pkgver}")
sha256sums=('SKIP')
-pkgver() {
- cd "$srcdir/Sia"
- git log -1 --format="%cd" --date=short --no-show-signature | sed "s|-||g"
-}
-
build() {
- msg2 'Building...'
+ cd "$srcdir/Sia"
+
export GOPATH="$srcdir"
- go get -v -u github.com/NebulousLabs/Sia/...
- cd "$GOPATH/src/github.com/NebulousLabs/Sia"
- make release-std
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+
+ make dependencies
+ make release
}
-package_siad() {
+package_siac() {
+ pkgdesc="Sia Client - $pkgdesc"
+ optdepends=('siad: sia daemon to interact with')
+
cd "$srcdir/Sia"
+ install -Dm 755 "$srcdir/bin/siac" -t "$pkgdir/usr/bin"
+}
- msg2 'Installing license...'
- install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/siad"
+package_siad() {
+ pkgdesc="Sia Daemon - $pkgdesc"
+ optdepends=('siac: cli tool to manage a siad instance')
- msg2 'Installing documentation...'
- install -dm 755 "$pkgdir/usr/share/doc/siad"
- cp -dpr --no-preserve=ownership README.md doc/* "$pkgdir/usr/share/doc/siad"
+ cd "$srcdir/Sia"
- msg2 'Installing...'
- for _bin in siac siad; do
- install -Dm 755 "$srcdir/bin/$_bin" -t "$pkgdir/usr/bin"
- done
+ install -Dm 644 "LICENSE" -t "$pkgdir/usr/share/licenses/sia"
+
+ install -dm 755 "$pkgdir/usr/share/doc/sia"
+ cp -dpr doc/* "$pkgdir/usr/share/doc/sia"
+
+ install -dm 755 "$pkgdir/usr/share/man/man1"
+ cp -dp doc/manpages/* "$pkgdir/usr/share/man/man1"
+
+ install -Dm 755 "$srcdir/bin/siad" -t "$pkgdir/usr/bin"
}