summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcel O'Neil2017-05-22 19:48:02 -0400
committerMarcel O'Neil2017-05-22 19:51:49 -0400
commit80271b97a2b988a52a5d7e21f7c2de6172e3250a (patch)
treeede515f7518bcfb158b0b9ea632f3bb610fdd4d5
downloadaur-80271b97a2b988a52a5d7e21f7c2de6172e3250a.tar.gz
Initial Commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
-rw-r--r--sia.desktop10
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..79dcdb246b73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = sia-ui
+ pkgdesc = Blockchain-based marketplace for file storage
+ pkgver = v1.2.2
+ pkgrel = 1
+ url = https://sia.tech
+ arch = x86_64
+ license = MIT
+ depends = gconf
+ depends = gtk2
+ depends = nss
+ depends = libxss
+ source = https://github.com/NebulousLabs/Sia-UI/releases/download/v1.2.2/Sia-UI-v1.2.2-linux-x64.zip
+ source = https://github.com/NebulousLabs/Sia-UI/raw/master/assets/siaLogo.svg
+ source = sia.desktop
+ sha256sums = ebdabe15c5ac14c19cc4af47cc1b16bf42efc8132093fbfed5a5ebe4c285d9e8
+ sha256sums = a02a534c151b49de1c6cb9f63502043ed3e06d0cbb058126198f821ec2a9a1c2
+ sha256sums = 56c2ee24ac0ed3f43579ecc77cae29f2f15ee75b505b01b9d37b30a2330cc489
+
+pkgname = sia-ui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f66145e27e6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Marcel O'Neil <marcel@marceloneil.com>
+
+pkgname=sia-ui
+_pkgname=sia
+pkgver=v1.2.2
+pkgrel=1
+pkgdesc="Blockchain-based marketplace for file storage"
+arch=('x86_64')
+url="https://sia.tech"
+license=('MIT')
+depends=('gconf' 'gtk2' 'nss' 'libxss')
+source=("https://github.com/NebulousLabs/Sia-UI/releases/download/${pkgver}/Sia-UI-${pkgver}-linux-x64.zip"
+ "https://github.com/NebulousLabs/Sia-UI/raw/master/assets/siaLogo.svg"
+ "${_pkgname}.desktop")
+sha256sums=('ebdabe15c5ac14c19cc4af47cc1b16bf42efc8132093fbfed5a5ebe4c285d9e8'
+ 'a02a534c151b49de1c6cb9f63502043ed3e06d0cbb058126198f821ec2a9a1c2'
+ '56c2ee24ac0ed3f43579ecc77cae29f2f15ee75b505b01b9d37b30a2330cc489')
+
+package() {
+
+ install -d $pkgdir/{opt/$pkgname,usr/bin}
+ cp -a * $pkgdir/opt/$pkgname
+ rm $pkgdir/opt/$pkgname/{Sia-UI-${pkgver}-linux-x64.zip,LICENSE*,version}
+ ln -s /opt/$pkgname/Sia-UI $pkgdir/usr/bin/$pkgname
+
+ # Launcher
+ install -Dm644 $srcdir/$_pkgname.desktop $pkgdir/usr/share/applications/$_pkgname.desktop
+
+ # Icons
+ install -Dm644 $srcdir/${_pkgname}Logo.svg \
+ $pkgdir/usr/share/icons/hicolor/scalable/apps/$_pkgname.svg
+}
diff --git a/sia.desktop b/sia.desktop
new file mode 100644
index 000000000000..4e94b6461bf5
--- /dev/null
+++ b/sia.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Sia
+Exec=sia-ui %f
+Icon=sia
+Comment=Blockchain-based marketplace for file storage
+Categories=Utility;
+Terminal=false
+StartupNotify=true