summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2020-01-15 20:42:33 +0100
committerNarrat2020-01-15 20:42:33 +0100
commitc13ca5feabbb2947c89f13f7b2a236f32434adba (patch)
tree25f9821f8082cb1deee6e2b2829baf0265684692
parentf36c6ffedcb3f6bd93b4b7f8cb356a068840063f (diff)
downloadaur-c13ca5feabbb2947c89f13f7b2a236f32434adba.tar.gz
fix build
Command substitution made the extraction fail. Additionally move the extracting part into prepare and adjust which icons to install. Finally quote every pkgdir/srcdir var
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD29
2 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d331e6d45dc9..76241b6dc08f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sia-ui
pkgdesc = Blockchain-based marketplace for file storage
pkgver = 1.4.2
- pkgrel = 1
+ pkgrel = 2
url = https://sia.tech
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index b11c8fddbbc0..867ac7a79a07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
-# Maintainer: Marcel O'Neil <marcel@marceloneil.com>
+# Contributor: Marcel O'Neil <marcel@marceloneil.com>
pkgname=sia-ui
_pkgname=Sia-UI
pkgver=1.4.2
_pkgver="v${pkgver}"
-pkgrel=1
+pkgrel=2
pkgdesc="Blockchain-based marketplace for file storage"
arch=('x86_64')
url="https://sia.tech"
@@ -13,34 +13,35 @@ depends=('gconf' 'gtk2' 'nss' 'libxss')
source=("https://sia.tech/releases/Sia-UI-${_pkgver}.AppImage")
sha256sums=('5727b01e0576201c17156078c99d8f8c810d5b73a682c99a4f64f3ec2212bec5')
-package() {
- cd $srcdir
+prepare() {
# extract files
chmod +x "Sia-UI-${_pkgver}.AppImage"
- `./Sia-UI-${_pkgver}.AppImage --appimage-extract`
+ ./Sia-UI-${_pkgver}.AppImage --appimage-extract
+}
+package() {
cd squashfs-root
# install icons
- for size in 16x16 24x24 32x32 48x48 64x64 96x96 128x128 256x256 512x512; do
+ for size in 16x16 32x32 48x48 64x64 128x128 256x256 512x512; do
install -Dm644 "usr/share/icons/hicolor/$size/apps/sia-ui.png" \
"$pkgdir/usr/share/icons/hicolor/$size/apps/sia-ui.png"
done
# install resources
- install -d $pkgdir/{opt/$pkgname,usr/bin}
- cp -a * $pkgdir/opt/$pkgname
- find $pkgdir/opt/$pkgname -type d -exec chmod 755 {} \;
- find $pkgdir/opt/$pkgname -type f -exec chmod 644 {} \;
- chmod -R +x $pkgdir/opt/$pkgname/resources/bin
+ install -d "$pkgdir"/{opt/${pkgname},usr/bin}
+ cp -a * "$pkgdir/opt/$pkgname"
+ find "$pkgdir/opt/$pkgname" -type d -exec chmod 755 {} \;
+ find "$pkgdir/opt/$pkgname" -type f -exec chmod 644 {} \;
+ chmod -R +x "$pkgdir/opt/$pkgname/resources/bin"
# link executable
- chmod +x $pkgdir/opt/$pkgname/$pkgname
- ln -s /opt/$pkgname/$pkgname $pkgdir/usr/bin/$pkgname
+ chmod +x "$pkgdir/opt/$pkgname/$pkgname"
+ ln -s /opt/$pkgname/$pkgname "$pkgdir/usr/bin/$pkgname"
# install desktop file
sed -e "s/AppRun/$pkgname/g" -i $pkgname.desktop
- install -Dm644 $pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ install -Dm644 $pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
}