summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-12-09 21:38:04 +0300
committerorhun2020-12-09 21:38:04 +0300
commit31e8d081b972e790e5dae7c9ea36812322c33dbb (patch)
tree1549b56841af9e1208d3737051ff960385dd7973
parent392f82d960c2b9cf45c582e708f02b65ef0f0b47 (diff)
downloadaur-31e8d081b972e790e5dae7c9ea36812322c33dbb.tar.gz
upgpkg: sic-image-cli 0.14.0-3
Add tests
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 52083060a585..fe3408197147 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,6 +21,11 @@ build() {
cargo build --release --locked --all-features
}
+check() {
+ cd "$_pkgname-$pkgver"
+ cargo test --release --locked
+}
+
package() {
cd "$_pkgname-$pkgver"
install -Dm 755 "target/release/$_pkgname" -t "$pkgdir/usr/bin"