summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-10-30 16:55:16 +0300
committerorhun2020-10-30 16:55:16 +0300
commit540cd90fe78141a62808f2d1b68b5cb81d04b7d4 (patch)
tree1a21ea5e1fbf4328041cb6b0d830456f2c334470
downloadaur-540cd90fe78141a62808f2d1b68b5cb81d04b7d4.tar.gz
Initial upload: sic-image-cli 0.14.0-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..210ba6585bce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = sic-image-cli
+ pkgdesc = Accessible image processing and conversion from the terminal
+ pkgver = 0.14.0
+ pkgrel = 1
+ url = https://github.com/foresterre/sic
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ source = sic-image-cli-0.14.0.tar.gz::https://github.com/foresterre/sic/archive/v0.14.0.tar.gz
+ sha512sums = SKIP
+
+pkgname = sic-image-cli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9114845be0b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=sic-image-cli
+_pkgname=sic
+pkgver=0.14.0
+pkgrel=1
+pkgdesc="Accessible image processing and conversion from the terminal"
+arch=('x86_64')
+url="https://github.com/foresterre/sic"
+license=('MIT')
+makedepends=('cargo')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha512sums=('SKIP')
+
+build() {
+ cd "$_pkgname-$pkgver"
+ cargo build --release --locked --all-features
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ install -Dm 755 "target/release/$_pkgname" -t "$pkgdir/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$_pkgname"
+ install -Dm 644 LICENSE-MIT -t "$pkgdir/usr/share/licenses/$_pkgname"
+}