summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122024-02-20 16:54:58 +0100
committerwillemw122024-02-20 16:54:58 +0100
commit965e5fb92861aa688cacf5d0ea617f1bc87afe0f (patch)
tree905c493f409f04044ca28a2370e44120d9df4f3f
parentfb4b99b2fab3d2c5a1c576b085d0901ee7675f7f (diff)
downloadaur-sickchill-git.tar.gz
Edit comments
Minor edits.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD34
2 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e22fce369491..44e6b39726e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sickchill-git
pkgdesc = Automatic video library manager for TV shows
- pkgver = 2022.7.20.r0
+ pkgver = 2024.2.18.r0
pkgrel = 1
url = https://sickchill.github.io
install = sickchill-git.install
diff --git a/PKGBUILD b/PKGBUILD
index bb3b79834917..41f703d16609 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,31 @@
# Maintainer: willemw <willemw12@gmail.com>
-# To install a specific release manually: comment out pkgver(), set the release in "pkgver=" and
-# at the end of the "pip install" line (change "sickchill" to "sickchill==<release>").
+# To install a specific SickChill release:
+# - comment out pkgver()
+# - set the release number in variable pkgver: pkgver=<release>
+# - set the release number at the end of the "pip install" line: change sickchill to sickchill==<release>
# This "PIP install" package is similar to a VCS package:
-# it has a pkgver() function and a reinstall will update the package.
-# That is the only reason why this package ends on -git.
+# it has a pkgver() function and a reinstall updates the package.
+# That is the only reason why this package ends on "-git".
pkgname=sickchill-git
-pkgver=2023.1.2.r0
+pkgver=2024.2.18.r0
pkgrel=1
-pkgdesc="Automatic video library manager for TV shows"
-arch=('any')
-url="https://sickchill.github.io"
-license=('GPL3')
-makedepends=('jq' 'python-virtualenv')
+pkgdesc='Automatic video library manager for TV shows'
+arch=(any)
+url=https://sickchill.github.io
+license=(GPL3)
+makedepends=(jq python-virtualenv)
optdepends=('libmediainfo: determine the resolution of MKV and AVI files with no resolution in the filename'
'unrar: for RAR files')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
options=('!strip')
install=$pkgname.install
-source=('sickchill.service'
- 'sickchill.sysusers'
- 'sickchill.tmpfiles')
+source=(sickchill.service
+ sickchill.sysusers
+ sickchill.tmpfiles)
sha256sums=('b417284472d804e634c0dcaac2876ca164ad9a485f947e0f05798d0ce1136d59'
'aaeb298c9717da8b28853ed15509fb8428d975ae49e8737ebcec15caab9f0978'
'2069f15e18fc7dd0f0f25b623f2067fc9028b1ca4122021a62364aa39914f88f')
@@ -48,9 +50,9 @@ build() {
package() {
install -Dm644 sickchill.service -t "$pkgdir/usr/lib/systemd/system"
- install -Dm644 sickchill.sysusers "$pkgdir/usr/lib/sysusers.d/sickchill.conf"
- install -Dm644 sickchill.tmpfiles "$pkgdir/usr/lib/tmpfiles.d/sickchill.conf"
+ install -Dm644 sickchill.sysusers "$pkgdir/usr/lib/sysusers.d/sickchill.conf"
+ install -Dm644 sickchill.tmpfiles "$pkgdir/usr/lib/tmpfiles.d/sickchill.conf"
install -dm755 "$pkgdir/opt/sickchill"
- cp -a build "$pkgdir/opt/sickchill/app"
+ cp -a build "$pkgdir/opt/sickchill/app"
}