summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122021-05-10 20:36:32 +0200
committerwillemw122021-05-10 20:36:32 +0200
commitb1016da28a9b549d218f9c70c7cd9a710d4003c5 (patch)
tree70b439fed9a3e0773e981f58e15b65fbbb2d214b
parentdba87b6ed265d21950bd8136f4737b2524690643 (diff)
downloadaur-b1016da28a9b549d218f9c70c7cd9a710d4003c5.tar.gz
Remove PIP --quiets options for easier troubleshooting...
Handle illegal characters in pkgver(). Replace "PIP_DEFAULT_TIMEOUT=60" with "--default-timeout=60". Minor edits.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0b8fe609d85..6d5882233a20 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sickchill-git
pkgdesc = Automatic video library manager for TV shows
- pkgver = 2020.11.24.post1.r0
- pkgrel = 2
+ pkgver = 2021.5.10.1.r0
+ pkgrel = 1
url = https://sickchill.github.io
install = sickchill-git.install
arch = any
@@ -9,7 +9,7 @@ pkgbase = sickchill-git
makedepends = jq
makedepends = python-virtualenv
optdepends = libmediainfo: determine the resolution of MKV and AVI files with no resolution in the filename
- optdepends = unrar: for RAR archives
+ optdepends = unrar: for RAR files
provides = sickchill
conflicts = sickchill
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index bd0faa19b7ea..c6a222d93f2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: willemw <willemw12@gmail.com>
-# NOTE This "PIP install" package is like a VCS package: it has a pkgver() function and to update do a reinstall.
+# NOTE This "PIP install" package is similar to a VCS package:
+# it has a pkgver() function and to update do a reinstall.
# That is the only reason why this package ends on -git.
pkgname=sickchill-git
-pkgver=2020.11.24.post1.r0
-pkgrel=2
+pkgver=2021.5.10.1.r0
+pkgrel=1
pkgdesc="Automatic video library manager for TV shows"
arch=('any')
url="https://sickchill.github.io"
license=('GPL3')
makedepends=('jq' 'python-virtualenv')
optdepends=('libmediainfo: determine the resolution of MKV and AVI files with no resolution in the filename'
- 'unrar: for RAR archives')
+ 'unrar: for RAR files')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
options=('!strip')
@@ -24,19 +25,19 @@ md5sums=('309b8555af7b355f16a3ec784771f426'
'97fb191af2e326d5aba2cf58270b4feb'
'515f13e391105a716ef6763ba8533fc7')
-export PIP_DEFAULT_TIMEOUT=60
-
pkgver() {
- curl -s "https://pypi.org/pypi/${pkgname%-git}/json" | jq --raw-output --join-output '.info.version'
- printf ".r0"
+ local version="$(curl -s "https://pypi.org/pypi/${pkgname%-git}/json" | jq --raw-output --join-output '.info.version')"
+ printf "%s.r0" "$version" | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
+ set -x
#python -m venv build
virtualenv --quiet build
- build/bin/pip install --quiet --quiet --isolated --no-warn-script-location --root=build --prefix=. sickchill
+ build/bin/pip install --isolated --no-warn-script-location --root=build --prefix=. --default-timeout=60 sickchill
sed -i '1s|.*|#!/opt/sickchill/app/bin/python|' build/bin/SickChill.py
+ set +x
}
package() {