summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOndrej Patrovic2016-06-22 08:02:46 -0400
committerOndrej Patrovic2016-06-22 08:02:46 -0400
commit522f797b4b651f1e0c988f0198087d4481e92c04 (patch)
treeaa9fe28cacd694c76a0f296adb206a3a252f7e55
parenta78f7694e757906ff964988a3c05103886c73e03 (diff)
downloadaur-522f797b4b651f1e0c988f0198087d4481e92c04.tar.gz
* Fixed tab spacing issues
* Updated checksum for sickgear.service * Fixed problem with .git directory not being copied
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD48
-rw-r--r--sickgear.install61
3 files changed, 75 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5c34d05fb44..e95714c1a57a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,35 @@
pkgbase = sickgear-git
pkgdesc = Provides management of TV shows and/or Anime, detects new episodes, links to downloader apps, and more.
pkgver = 0.11.12.r0.g9198eb6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/SickGear/SickGear
install = sickgear.install
arch = any
license = GPL3
makedepends = git
depends = python2-cheetah
+ optdepends = sabnzbd: supported NZB downloader
+ optdepends = transmission-cli: supported torrent client
+ optdepends = deluge: supported torrent client
+ optdepends = rtorrent: supported torrent client
+ optdepends = qbittorrent: supported torrent client
optdepends = python2-notify: desktop notifications
optdepends = python2-pyopenssl: enable SSL
- optdepends = unrar: RAR archives
+ optdepends = unrar: RAR extraction support
+ optdepends = git: pull new versions from git
provides = sickgear
conflicts = sickgear
+ conflicts = sickbeard
+ conflicts = sickrage
+ conflicts = sickrage-git
+ conflicts = sickrage2-git
options = !strip
source = sickgear.service
source = sickgear.tmpfiles
source = sickgear.sysusers
source = fix-signal-handling.patch
source = sickgear::git+https://github.com/SickGear/SickGear.git
- sha256sums = 1b80f3f749e357e1509dd4524eecb3f044ec0a266cf96c31f665dabb7fe07f8f
+ sha256sums = 76108d56417bc6e5352db779c7e74812eda07b440cc293547809aa9504e10209
sha256sums = 5c7a327168f2b2d361eeaa9e9f82e79a87381908d8ba6b1d1eb90ac64ad38ac2
sha256sums = 54873ee12aa334a0c0830dbe48251f994d8ae851ae0b55250c098ff9f7f9ea60
sha256sums = fae4616bf9dbf19d5bb2fcc89abd49b27db9f1f0181589a60bbcde07b840ae99
diff --git a/PKGBUILD b/PKGBUILD
index 6ec022c735cf..e488fa12f84d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,30 +3,38 @@
_pkgname=sickgear
pkgname=${_pkgname}-git
pkgver=0.11.12.r0.g9198eb6
-pkgrel=1
+pkgrel=2
pkgdesc="Provides management of TV shows and/or Anime, detects new episodes, links to downloader apps, and more."
arch=('any')
url="https://github.com/SickGear/SickGear"
license=('GPL3')
makedepends=('git')
depends=('python2-cheetah')
-optdepends=('python2-notify: desktop notifications'
+optdepends=('sabnzbd: supported NZB downloader'
+ 'transmission-cli: supported torrent client'
+ 'deluge: supported torrent client'
+ 'rtorrent: supported torrent client'
+ 'qbittorrent: supported torrent client'
+ 'python2-notify: desktop notifications'
'python2-pyopenssl: enable SSL'
- 'unrar: RAR archives')
+ 'unrar: RAR extraction support'
+ 'git: pull new versions from git')
provides=(${_pkgname})
-conflicts=(${_pkgname})
+conflicts=(${_pkgname}
+ 'sickbeard'
+ 'sickrage'
+ 'sickrage-git'
+ 'sickrage2-git')
options=('!strip')
install=${_pkgname}.install
-source=(
- "sickgear.service"
- "sickgear.tmpfiles"
- "sickgear.sysusers"
- "fix-signal-handling.patch"
- "${_pkgname}::git+https://github.com/SickGear/SickGear.git"
-)
+source=('sickgear.service'
+ 'sickgear.tmpfiles'
+ 'sickgear.sysusers'
+ 'fix-signal-handling.patch'
+ "${_pkgname}::git+https://github.com/SickGear/SickGear.git")
-sha256sums=('1b80f3f749e357e1509dd4524eecb3f044ec0a266cf96c31f665dabb7fe07f8f'
+sha256sums=('76108d56417bc6e5352db779c7e74812eda07b440cc293547809aa9504e10209'
'5c7a327168f2b2d361eeaa9e9f82e79a87381908d8ba6b1d1eb90ac64ad38ac2'
'54873ee12aa334a0c0830dbe48251f994d8ae851ae0b55250c098ff9f7f9ea60'
'fae4616bf9dbf19d5bb2fcc89abd49b27db9f1f0181589a60bbcde07b840ae99'
@@ -38,16 +46,18 @@ pkgver() {
}
prepare() {
- cd "${_pkname}"
- patch -Np1 -i "${srcdir}/fix-signal-handling.patch"
+ cd "${_pkname}"
+
+ # Patch to fix SIGINT and SIGTERM signal handling
+ patch -Np1 -i "${srcdir}/fix-signal-handling.patch"
}
package() {
- install -dm 755 "${pkgdir}"/{opt/sickgear/app,usr/lib/{tmpfiles.d,sysusers.d,systemd/system}}
+ install -dm 755 "${pkgdir}"/{opt/sickgear/app,usr/lib/{tmpfiles.d,sysusers.d,systemd/system}}
- cp -dr --no-preserve=ownership "${_pkgname}"/* "${pkgdir}/opt/sickgear/app/"
+ cp -dRT --no-preserve=ownership "${_pkgname}/" "${pkgdir}/opt/sickgear/app/"
- install -m 644 sickgear.service "${pkgdir}/usr/lib/systemd/system/"
- install -m 644 sickgear.tmpfiles "${pkgdir}/usr/lib/tmpfiles.d/sickgear.conf"
- install -m 644 sickgear.sysusers "${pkgdir}/usr/lib/sysusers.d/sickgear.conf"
+ install -m 644 sickgear.service "${pkgdir}/usr/lib/systemd/system/"
+ install -m 644 sickgear.tmpfiles "${pkgdir}/usr/lib/tmpfiles.d/sickgear.conf"
+ install -m 644 sickgear.sysusers "${pkgdir}/usr/lib/sysusers.d/sickgear.conf"
}
diff --git a/sickgear.install b/sickgear.install
index fe3f623bcdcb..f0904ae2cf18 100644
--- a/sickgear.install
+++ b/sickgear.install
@@ -1,64 +1,69 @@
post_install() {
- systemd-sysusers sickgear.conf
- systemd-tmpfiles --create sickgear.conf
+ systemd-sysusers sickgear.conf
+ systemd-tmpfiles --create sickgear.conf
- if [ ! -d /opt/sickgear/data ]; then
- mkdir -p -m 755 /opt/sickgear/data &> /dev/null
+ if [ ! -d /opt/sickgear/data ]; then
+ mkdir -p -m 755 /opt/sickgear/data &> /dev/null
cat << 'EOM'
==> In order to start SickGear, you must issue the following command:
- systemctl start sickgear.service
+ systemctl start sickgear.service
==> To have SickGear start automatically on system startup and after
==> version upgrades, also issue the following command:
-
- systemctl enable sickgear.service
+
+ systemctl enable sickgear.service
==> Once started, SickGear can be accessed by navigating your browser to:
- http://localhost:8081/
+ http://localhost:8081/
EOM
- fi
+ fi
- chown -R sickgear:sickgear /opt/sickgear &> /dev/null
+ chown -R sickgear:sickgear /opt/sickgear &> /dev/null
}
pre_upgrade() {
- if systemctl is-active sickgear.service &> /dev/null; then
- systemctl stop sickgear.service &> /dev/null
- fi
+ if systemctl is-active sickgear.service &> /dev/null; then
+ systemctl stop sickgear.service &> /dev/null
+ fi
}
post_upgrade() {
- post_install
- systemctl daemon-reload &> /dev/null
+ post_install
+ systemctl daemon-reload &> /dev/null
- if systemctl is-enabled sickgear.service &> /dev/null; then
- systemctl start sickgear.service
- fi
+ if systemctl is-enabled sickgear.service &> /dev/null; then
+ systemctl start sickgear.service
+ fi
}
pre_remove() {
- pre_upgrade
+ pre_upgrade
- if systemctl is-enabled sickgear.service &> /dev/null; then
- systemctl disable sickgear.service &> /dev/null
- fi
+ if systemctl is-enabled sickgear.service &> /dev/null; then
+ systemctl disable sickgear.service &> /dev/null
+ fi
}
post_remove() {
- if ! rmdir /opt/sickgear/data &> /dev/null; then
+ # Clean up leftovers (cached python files)
+ if [ -d /opt/sickgear/app ]; then
+ rm -fR /opt/sickgear/app &> /dev/null
+ fi
+
+ if ! rmdir /opt/sickgear/data &> /dev/null; then
cat << 'EOM'
==> Data directory has not been removed since it contains files.
-==> If you no longer want your show data, you may removing it by issuing
-==> the following command:
+==> If you no longer want your show data, you may removing it by issuing
+==> the following command as root:
- rm -rf /opt/sickgear
+ rm -rf /opt/sickgear
EOM
- fi
-} \ No newline at end of file
+ fi
+}