summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122017-04-04 10:10:38 +0200
committerwillemw122017-04-04 10:10:38 +0200
commit9c756ad1cfb506382c22249c7189ec642a4f69bf (patch)
tree32ce01ffcfab1bcecf3c0ae09dc20f48bddd025d
parenta5e81d80438be7c92c912b0675f172327e531b46 (diff)
downloadaur-9c756ad1cfb506382c22249c7189ec642a4f69bf.tar.gz
Move python2-notify to optdepends. Colored install messages
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
-rw-r--r--sickrage-git.install14
3 files changed, 24 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 960447a2a4ae..691239423674 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sickrage-git
pkgdesc = A PVR application that downloads and manages your TV shows. Echel0n fork of sickbeard, with tvrage, torrents and anime support.
- pkgver = 8.8.4.r41.g10d0371b3
- pkgrel = 2
+ pkgver = 8.8.4.r85.gb1b4f64e5
+ pkgrel = 1
url = https://github.com/SiCKRAGETV/SickRage
install = sickrage-git.install
arch = any
@@ -10,9 +10,9 @@ pkgbase = sickrage-git
depends = python2-apscheduler
depends = python2-cheetah
depends = python2-mako
- depends = python2-notify
depends = python2-tornado
depends = python2-tzlocal
+ optdepends = python2-notify: desktop notifications
optdepends = python2-pyopenssl: enable SSL
optdepends = unrar: RAR archives
provides = sickrage
diff --git a/PKGBUILD b/PKGBUILD
index ca3adbd39383..d4e6b1d605e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pkgname=sickrage
pkgname=$_pkgname-git
-pkgver=8.8.4.r41.g10d0371b3
-pkgrel=2
+pkgver=8.8.4.r85.gb1b4f64e5
+pkgrel=1
pkgdesc="A PVR application that downloads and manages your TV shows. Echel0n fork of sickbeard, with tvrage, torrents and anime support."
arch=('any')
url="https://github.com/SiCKRAGETV/SickRage"
@@ -13,15 +13,15 @@ makedepends=('git')
depends=('python2-apscheduler'
'python2-cheetah'
'python2-mako'
- 'python2-notify'
'python2-tornado'
'python2-tzlocal')
-# 'deluge: supported torrent client'
-# 'qbittorrent: supported torrent client'
-# 'rtorrent: supported torrent client'
-# 'sabnzbd: supported NZB downloader'
-# 'transmission-cli: supported torrent client'
-optdepends=('python2-pyopenssl: enable SSL'
+# 'deluge: torrent client'
+# 'qbittorrent: torrent client'
+# 'rtorrent: torrent client'
+# 'sabnzbd: NZB downloader'
+# 'transmission-cli: torrent client'
+optdepends=('python2-notify: desktop notifications'
+ 'python2-pyopenssl: enable SSL'
'unrar: RAR archives')
provides=($_pkgname)
conflicts=($_pkgname)
diff --git a/sickrage-git.install b/sickrage-git.install
index 28a129e18b8d..d1e1b2fb8290 100644
--- a/sickrage-git.install
+++ b/sickrage-git.install
@@ -1,16 +1,26 @@
+# Colored makepkg-like functions
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
post_install() {
systemd-sysusers sickrage.conf
systemd-tmpfiles --create sickrage.conf
chown -R sickrage:sickrage /opt/sickrage
- echo "==> Configuration files have moved to /opt/sickrage/data. To migrate, run the following commands as root and then reinstall:"
+ note "Configuration files have moved to /opt/sickrage/data."
+ echo " To migrate, run the following commands as root and then reinstall:"
echo " systemctl stop sickrage.service"
echo " pacman -Rn sickrage-git"
echo " cp -a /opt/sickrage{,.bak}"
echo ' rm -r $(ls -1d /opt/sickrage/* | grep -Ev "/backup.*|/cache.*|/config.ini.*|/Log.*|/.*\.db.*")'
echo " mkdir -p /opt/sickrage/data"
echo " mv /opt/sickrage/* /opt/sickrage/data/"
+ note "If an upgrade fails with \"error: failed to commit transaction (conflicting files)\", then uninstall first."
echo "==> Start and enable sickrage.service. Then visit http://localhost:8081/"
- echo "==> If an upgrade fails with \"error: failed to commit transaction (conflicting files)\", then uninstall first."
}
post_upgrade() {