summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKljunas22024-03-09 14:48:05 +0100
committerKljunas22024-03-09 14:48:53 +0100
commit0d593309ac5b787dfce40cf8e5909f00914a8100 (patch)
tree12eebdf72b85bf050ecd19fa61480357a5507b98
parentd50c3e4d48076ea671ce9c2de066f22cd3d45219 (diff)
downloadaur-0d593309ac5b787dfce40cf8e5909f00914a8100.tar.gz
Add LICENSE and bash as a dependency
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore4
-rw-r--r--LICENSE24
-rw-r--r--PKGBUILD25
4 files changed, 47 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9182ba2849f..362e46e17731 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
pkgbase = sictools
pkgdesc = Tools for SIC/XE hypotetical computer
pkgver = 2.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jurem/SicTools
arch = any
- license = unknown
+ license = BSD-2-Clause
depends = java-runtime
+ depends = bash
source = sictools.jar::https://github.com/jurem/SicTools/releases/download/v2.1.0/sictools.jar
source = sictools
source = sictools.desktop
+ source = LICENSE
sha512sums = 7ced5bf922efabf80b0cffa1f344de7526b3f85d65b1969eb7ef8e43d7d32556552e9e033cb80a2bb107f2c5601999bdd79d808445f5a2e2a4a2f427f0854238
sha512sums = edeec714008b00667420bdd881ceeec5b66e97b83a7ba34888f3a09f00a719b9db5a546553035bcb1bc1860ba396f13343e1be0f0f590922dd640015e538149f
sha512sums = aefa3d24d550160685778af9a687c18425534535fcf6c1309ab744de1916e9b41bfdce24bc206b7453150a688840b0892e72a1279f3be6c4ac292816744c8e81
+ sha512sums = 16e77873ddfed0d43bfa26f262ea23cf17cf02503816cb94bacd6a25d700c77aca64fb3f69903003bbfabbed85fd38b375602b55c052d96f3ae74fc4467eff54
pkgname = sictools
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..011bae62ea74
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+sictools.jar
+*.tar.zst
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..0baaab268ca4
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,24 @@
+Copyright (c) 2015 Jurij Mihelič
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+1. Redistributions of source code must retain the above copyright notice, this
+ list of conditions and the following disclaimer.
+ 2. Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+
+ THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+ ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+ WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+ DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR
+ ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+ (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+ LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+ ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+ (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+ SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+ http://www.opensource.org/licenses/BSD-2-Clause
diff --git a/PKGBUILD b/PKGBUILD
index 0bcec8c9d446..ef853512a3c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,25 @@
pkgname=sictools
pkgver=2.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Tools for SIC/XE hypotetical computer"
arch=("any")
-license=("unknown")
+license=("BSD-2-Clause")
url="https://github.com/jurem/SicTools"
-depends=("java-runtime")
+depends=("java-runtime" "bash")
source=("${pkgname}.jar::${url}/releases/download/v${pkgver}/${pkgname}.jar"
"sictools"
- "sictools.desktop")
-sha512sums=("7ced5bf922efabf80b0cffa1f344de7526b3f85d65b1969eb7ef8e43d7d32556552e9e033cb80a2bb107f2c5601999bdd79d808445f5a2e2a4a2f427f0854238"
- "edeec714008b00667420bdd881ceeec5b66e97b83a7ba34888f3a09f00a719b9db5a546553035bcb1bc1860ba396f13343e1be0f0f590922dd640015e538149f"
- "aefa3d24d550160685778af9a687c18425534535fcf6c1309ab744de1916e9b41bfdce24bc206b7453150a688840b0892e72a1279f3be6c4ac292816744c8e81"
-)
+ "sictools.desktop"
+ "LICENSE"
+ )
+sha512sums=('7ced5bf922efabf80b0cffa1f344de7526b3f85d65b1969eb7ef8e43d7d32556552e9e033cb80a2bb107f2c5601999bdd79d808445f5a2e2a4a2f427f0854238'
+ 'edeec714008b00667420bdd881ceeec5b66e97b83a7ba34888f3a09f00a719b9db5a546553035bcb1bc1860ba396f13343e1be0f0f590922dd640015e538149f'
+ 'aefa3d24d550160685778af9a687c18425534535fcf6c1309ab744de1916e9b41bfdce24bc206b7453150a688840b0892e72a1279f3be6c4ac292816744c8e81'
+ '16e77873ddfed0d43bfa26f262ea23cf17cf02503816cb94bacd6a25d700c77aca64fb3f69903003bbfabbed85fd38b375602b55c052d96f3ae74fc4467eff54')
package() {
- install -D -m755 ${pkgname} "${pkgdir}/usr/bin/${pkgname}"
- install -D -m644 ${pkgname}.jar "${pkgdir}/usr/share/java/${pkgname}/${pkgname}.jar"
- install -D -m644 ${pkgname}.desktop "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -D -m755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m644 "${pkgname}.jar" "${pkgdir}/usr/share/java/${pkgname}/${pkgname}.jar"
+ install -D -m644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}