summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilk Brewster2018-08-15 14:52:09 +0100
committerMilk Brewster2018-08-15 14:52:09 +0100
commit94d382f44df42ae66decde87e50c5ed3dfabd943 (patch)
tree392d09d74b770bfd7d0a33784f8567f25e37e6d7
parent2719c9029dc0616471d0fa767a3a1050213d07d1 (diff)
downloadaur-94d382f44df42ae66decde87e50c5ed3dfabd943.tar.gz
fixed build
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD41
2 files changed, 27 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e312bcf032c..be4192a98fca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sid-vst-git
pkgdesc = Emulates MOS Technology SID audio chip (used in Commodore 64) as a VST
- pkgver = r24.57d3bbf
+ pkgver = r35.577954f
pkgrel = 1
url = http://socalabs.com/
arch = i686
@@ -12,11 +12,13 @@ pkgbase = sid-vst-git
source = SID::git+https://github.com/FigBug/SID.git
source = dRowAudio::git+https://github.com/FigBug/drowaudio.git#commit=3a1e6eb75681b166c055c501a2ed4a8df8a44df0
source = slCommon::git+https://github.com/FigBug/slCommon.git#commit=b49d31c4f2f131506fe5ac53f2ac6e47b3ee109b
+ source = gin::git+https://github.com/FigBug/Gin
source = JUCE::git+https://github.com/WeAreROLI/JUCE.git#branch=develop
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
pkgname = sid-vst-git
diff --git a/PKGBUILD b/PKGBUILD
index aac833b8ca1f..b949f664c1a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
+# Maintainer: Milk Brewster < milk on freenode >
# Maintainer: Lukas Sabota <lukas _at_ lwsabota _dot_ com>
# Contributer: Lukas Sabota <lukas _at_ lwsabota _dot_ com>
pkgname=sid-vst-git
_gitbase=SID
-pkgver=r24.57d3bbf
+pkgver=r35.577954f
pkgrel=1
pkgdesc="Emulates MOS Technology SID audio chip (used in Commodore 64) as a VST"
arch=('i686' 'x86_64')
@@ -12,35 +13,41 @@ groups=('socalabs-vst-suite')
depends=('mesa')
makedepends=('git')
source=('SID::git+https://github.com/FigBug/SID.git'
- 'dRowAudio::git+https://github.com/FigBug/drowaudio.git#commit=3a1e6eb75681b166c055c501a2ed4a8df8a44df0'
- 'slCommon::git+https://github.com/FigBug/slCommon.git#commit=b49d31c4f2f131506fe5ac53f2ac6e47b3ee109b'
- 'JUCE::git+https://github.com/WeAreROLI/JUCE.git#branch=develop')
+ 'dRowAudio::git+https://github.com/FigBug/drowaudio.git#commit=3a1e6eb75681b166c055c501a2ed4a8df8a44df0'
+ 'slCommon::git+https://github.com/FigBug/slCommon.git#commit=b49d31c4f2f131506fe5ac53f2ac6e47b3ee109b'
+ 'gin::git+https://github.com/FigBug/Gin'
+ 'JUCE::git+https://github.com/WeAreROLI/JUCE.git#branch=develop')
# Note: This package requires features in the develop branch of JUCE
# This package can likely be moved to depend on the juce AUR package
# after an upstream JUCE release.
# FYI: This can be accomplished by symlinking /opt/JUCE to $srcdir/JUCE
# in the future.
-md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP')
+md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
pkgver() {
- cd "$srcdir/$_gitbase"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/$_gitbase"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd "$srcdir/$_gitbase"
- # Workaround for SSH-only configured submodule remotes
- cd modules
- rm -rf dRowAudio slCommon
- ln -s ../../dRowAudio ./
- ln -s ../../slCommon ./
+ cd "$srcdir/$_gitbase"
+ # Workaround for SSH-only configured submodule remotes
+ cd modules
+ rm -rf dRowAudio slCommon
+ ln -s ../../slCommon ./
+
+ cd "$srcdir/$_gitbase"
+ cd plugin/JuceLibraryCode
+ mv ../../../JUCE/modules/* .
+ ln -s ../../../dRowAudio/module/dRowAudio dRowAudio
+ ln -s ../../../gin/modules/gin gin
}
build() {
- cd "$srcdir/$_gitbase/plugin/Builds/LinuxMakefile"
- make
+ cd "$srcdir/$_gitbase/plugin/Builds/LinuxMakefile"
+ make
}
package() {
- install -D -m644 "$srcdir/$_gitbase/plugin/Builds/LinuxMakefile/build/$_gitbase.so" "$pkgdir/usr/lib/vst/$_gitbase.so"
-}
+ install -D -m644 "$srcdir/$_gitbase/plugin/Builds/LinuxMakefile/build/$_gitbase.so" "$pkgdir/usr/lib/vst/$_gitbase.so"
+ }