aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJordan Day2017-03-29 10:39:03 -0500
committerJordan Day2017-03-29 10:43:26 -0500
commit2fa9d88cef5ad040d5a6a49700b6b19bcb771111 (patch)
treee67002a2685fc91942af56ee91a8be52fb3557ca
downloadaur-2fa9d88cef5ad040d5a6a49700b6b19bcb771111.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
-rw-r--r--README.md1
4 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e98aea25ab5d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = siddasm
+ pkgdesc = Written by Gufino, this program produces disassembler output of .SID music files, so that you'll be able to see the musicroutine code.
+ pkgver = 1.0
+ pkgrel = 0
+ url = http://cadaver.homeftp.net/tools.htm
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = gcc
+ provides = siddasm
+ source = http://cadaver.homeftp.net/tools/siddasm1.tar.gz
+ md5sums = f73d5109a777a09751c7e742a39551a9
+
+pkgname = siddasm
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a186f1b1ab91
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/*
+src/*
+*.xz
+*.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9124ea3c66ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jordan Day < jordanday444 at gmail dot com >
+
+pkgname=siddasm
+pkgver=1.0
+pkgrel=0
+pkgdesc="Written by Gufino, this program produces disassembler output of .SID music files, so that you'll be able to see the musicroutine code."
+arch=('i686' 'x86_64')
+url="http://cadaver.homeftp.net/tools.htm"
+source=(http://cadaver.homeftp.net/tools/siddasm1.tar.gz)
+license=('custom')
+provides=("$pkgname")
+makedepends=('gcc')
+
+build() {
+ cd "$srcdir"
+ gcc -o $pkgname siddasm1.c
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ install -Dm755 ./$pkgname "$pkgdir/usr/bin"
+}
+md5sums=('f73d5109a777a09751c7e742a39551a9')
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..d259a304eb7b
--- /dev/null
+++ b/README.md
@@ -0,0 +1 @@
+aur-SIDDasm