summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2019-10-07 22:06:18 -0400
committerAdam Goldsmith2019-10-08 00:04:11 -0400
commit5a6e61b4249642c7db9624cbbfb1fc4417b1eba5 (patch)
tree49144cc91e6d633b85e6b251ec04faea738eba5c
downloadaur-5a6e61b4249642c7db9624cbbfb1fc4417b1eba5.tar.gz
Initial Commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD50
-rw-r--r--SideQuest.desktop10
-rw-r--r--openUrl-fix.patch14
-rwxr-xr-xsidequest3
6 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f025ffb5cab6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = sidequest-git
+ pkgdesc = A tool to help simplify getting content onto Oculus Quest, Go, and other VR headsets.
+ pkgver = v0.7.2
+ pkgrel = 1
+ url = https://sidequestvr.com/
+ arch = any
+ license = MIT
+ makedepends = yarn
+ depends = electron4
+ options = !strip
+ source = git+https://github.com/the-expanse/SideQuest
+ source = sidequest
+ source = openUrl-fix.patch
+ source = SideQuest.desktop
+ md5sums = SKIP
+ md5sums = ef9bbe8b6707d3f195c6982a289f142a
+ md5sums = fd5699b1645ccd0163ab144837295e4c
+ md5sums = aa393219b320d8b96c83714882de8b32
+
+pkgname = sidequest-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..80c21466310a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/*.pkg*
+/SideQuest/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf8c19dbe605
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
+
+pkgname=sidequest-git
+_pkgname=SideQuest
+pkgver=v0.7.2
+pkgrel=1
+pkgdesc="A tool to help simplify getting content onto Oculus Quest, Go, and other VR headsets."
+arch=('any')
+url="https://sidequestvr.com/"
+license=('MIT')
+depends=(electron4)
+makedepends=(yarn)
+options=(!strip)
+source=("git+https://github.com/the-expanse/SideQuest"
+ "sidequest"
+ "openUrl-fix.patch"
+ "SideQuest.desktop")
+md5sums=('SKIP'
+ 'ef9bbe8b6707d3f195c6982a289f142a'
+ 'fd5699b1645ccd0163ab144837295e4c'
+ 'aa393219b320d8b96c83714882de8b32')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --tags | sed 's/-/./g'
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ patch -p1 -i "${srcdir}/openUrl-fix.patch"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ yarn install
+ yarn dist
+}
+
+package() {
+ install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm755 "${_pkgname,,}" "$pkgdir/usr/bin/${_pkgname,,}"
+
+ cd "${srcdir}/${_pkgname}"
+
+ install -Dm644 "build/icons/512x512.png" "${pkgdir}/usr/share/icons/hicolor/512x512/apps/${_pkgname,,}.png"
+ install -Dm644 "dist/linux-unpacked/resources/app.asar" "${pkgdir}/usr/share/${_pkgname}/app.asar"
+ cp -r --no-preserve=mode,ownership "dist/linux-unpacked/resources/app.asar.unpacked" "${pkgdir}/usr/share/${_pkgname}/"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/SideQuest.desktop b/SideQuest.desktop
new file mode 100644
index 000000000000..375886d78eec
--- /dev/null
+++ b/SideQuest.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=SideQuest
+Comment=A tool to help simplify getting content onto Quest and Go and other VR headsets.
+Exec=sidequest %u
+Terminal=false
+Type=Application
+Icon=sidequest
+Categories=Development;Game;HardwareSettings
+StartupWMClass=SideQuest
+MimeType=x-scheme-handler/sidequest; \ No newline at end of file
diff --git a/openUrl-fix.patch b/openUrl-fix.patch
new file mode 100644
index 000000000000..74e595351c1e
--- /dev/null
+++ b/openUrl-fix.patch
@@ -0,0 +1,14 @@
+--- a/app.js
++++ b/app.js
+@@ -128,9 +128,9 @@ function setupMenu() {
+
+ const gotTheLock = app.requestSingleInstanceLock ? app.requestSingleInstanceLock() : true;
+ let parseOpenUrl = argv => {
+- if (argv[1] && argv[1].length && argv[1].substr(0, 12) === 'sidequest://') {
++ if (argv[2] && argv[2].length && argv[2].substr(0, 12) === 'sidequest://') {
+ //fs.writeFileSync(path.join(app.getPath('appData'), 'SideQuest', 'test_output_loaded.txt'), argv[1].toString());
+- mainWindow.webContents.send('open-url', argv[1].toString());
++ mainWindow.webContents.send('open-url', argv[2].toString());
+ }
+ };
+
diff --git a/sidequest b/sidequest
new file mode 100755
index 000000000000..d9a351a7d6c6
--- /dev/null
+++ b/sidequest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec electron4 /usr/share/SideQuest/app.asar "$@"