summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Perry (Pezz)2015-06-10 14:05:39 +1000
committerSimon Perry (Pezz)2015-06-10 14:05:39 +1000
commit8727dd7cbf926cbadd2d98c6bd9f08d71387abfe (patch)
tree081f24b872f500d284743e826bf6f91a2e80ca9b
downloadaur-8727dd7cbf926cbadd2d98c6bd9f08d71387abfe.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
-rw-r--r--sidplayfp.install39
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f5e365a6f99
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = sidplayfp
+ pkgdesc = Sidplay2 fork with improved filter emulation
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = http://sourceforge.net/projects/sidplay-residfp/
+ install = sidplayfp.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libsidplayfp>=1.7.1
+ conflicts = sidplay-residfp
+ conflicts = sidplay-residfp-alsa
+ conflicts = sidplay-residfp-pulse
+ source = http://downloads.sourceforge.net/project/sidplay-residfp/sidplayfp/1.3/sidplayfp-1.3.1.tar.gz
+ sha256sums = 6bd10bf6eb40f60d4ba4efaf4325c82203f00af229be1b537ff0163eedd7e32d
+
+pkgname = sidplayfp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da46a9bde6bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Simon Perry <aur [at] sanxion [dot] net>
+# Contributor: Jonas Nyrén <jonas.nyren*mindkiller.com>
+
+pkgname=sidplayfp
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="Sidplay2 fork with improved filter emulation"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/sidplay-residfp/"
+license=('GPL')
+depends=('libsidplayfp>=1.7.1')
+reaplces=('sidplay-residfp' 'sidplay-residfp-alsa' 'sidplay-residfp-pulse')
+conflicts=('sidplay-residfp' 'sidplay-residfp-alsa' 'sidplay-residfp-pulse')
+install=${pkgname}.install
+source=("http://downloads.sourceforge.net/project/sidplay-residfp/sidplayfp/1.3/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('6bd10bf6eb40f60d4ba4efaf4325c82203f00af229be1b537ff0163eedd7e32d')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+}
+
diff --git a/sidplayfp.install b/sidplayfp.install
new file mode 100644
index 000000000000..ecb38440d6a7
--- /dev/null
+++ b/sidplayfp.install
@@ -0,0 +1,39 @@
+pkgname=sidplay-residfp
+
+post_install() {
+ cat << _EOF
+
+- A default configuration is created in:
+- ~/.config/sidplayfp/sidplayfp.ini
+- on the first run.
+-
+- Edit to suit your needs.
+-
+- Some SIDs also need C64 ROM files in order to play correctly!
+-
+- Install the VICE C64 emulator and use the ROM files found in:
+- /usr/lib/vice/C64 and set the appropriate ini options for
+- kernel, basic and chargen ROMs.
+
+_EOF
+}
+
+post_upgrade() {
+ cat << _EOF
+
+- A default configuration is now created in:
+- ~/.config/sidplayfp/sidplayfp.ini
+- on the first run.
+-
+- Edit to suit your needs or migrate your old configuration from:
+- ~/.sidplay/sidplay2.ini (taking note of any diffs)
+-
+- Some SIDs also need C64 ROM files in order to play correctly!
+-
+- Install the VICE C64 emulator and use the ROM files found in:
+- /usr/lib/vice/C64 and set the appropriate ini options for
+- kernel, basic and chargen ROMs.
+
+_EOF
+}
+