summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraxionl2018-07-02 02:32:38 +0800
committeraxionl2018-07-02 02:32:38 +0800
commit4750f7cb07b6728eae459edb83caa70c48c0e7b6 (patch)
tree960dac62bf1014be06b49b18ab00337d6ca73beb
downloadaur-4750f7cb07b6728eae459edb83caa70c48c0e7b6.tar.gz
Add this package
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD56
-rw-r--r--sielo-browser.desktop7
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..35549e959737
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = sielo-browser-git
+ pkgdesc = A simple, customizable and fast web browser
+ pkgver = r1071.0787986
+ pkgrel = 1
+ url = https://github.com/SieloBrowser/SieloBrowser
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ makedepends = imagemagick
+ makedepends = qt5-webchannel
+ makedepends = qt5-location
+ makedepends = qt5-declarative
+ depends = qt5-webengine
+ provides = sielo-browser
+ conflicts = sielo-browser
+ source = sielo-browser-git::git+https://github.com/SieloBrowser/SieloBrowser
+ source = https://raw.githubusercontent.com/SieloBrowser/SieloBrowser/master/LICENSE
+ source = sielo-browser.desktop
+ sha256sums = SKIP
+ sha256sums = 4188f2493b00dc3c8f3ec23485a1af12d6b50cc4e3273bc47cee9c1580f5e4c3
+ sha256sums = cd42f495ac22e2cf46441d59839bcb0a744b7b368392cbbdc85763e305759af7
+
+pkgname = sielo-browser-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3dbefe2a9f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Ariel AxionL <axionl@aosc.io>
+pkgname=sielo-browser-git
+_pkgname=sielo-browser
+pkgver=r1071.0787986
+pkgrel=1
+pkgdesc="A simple, customizable and fast web browser"
+arch=('x86_64')
+depends=('qt5-webengine')
+makedepends=('git' 'cmake' 'imagemagick'
+ 'qt5-webchannel' 'qt5-location' 'qt5-declarative')
+conflicts=("sielo-browser")
+provides=("sielo-browser")
+url="https://github.com/SieloBrowser/SieloBrowser"
+license=('MIT')
+
+source=("$pkgname::git+${url}"
+ "https://raw.githubusercontent.com/SieloBrowser/SieloBrowser/master/LICENSE"
+ "${_pkgname}.desktop")
+
+sha256sums=('SKIP'
+ '4188f2493b00dc3c8f3ec23485a1af12d6b50cc4e3273bc47cee9c1580f5e4c3'
+ 'cd42f495ac22e2cf46441d59839bcb0a744b7b368392cbbdc85763e305759af7')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${pkgname}
+ mkdir build && cd build
+ cmake -DCMAKE_BUILD_TYPE=Release ..
+ make -j $(grep -c processor /proc/cpuinfo)
+
+ cd ..
+ for i in 16 24 32 48 64 96 128 256; do
+ mkdir -p icon/${i}x${i}/apps
+ convert icons/other/ic_sielo.png -resize ${i}x${i} icon/${i}x${i}/apps/${_pkgname}.png
+ done
+}
+
+package() {
+ # License
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+
+ # Install Icons and desktop file
+ install -Dm644 ${_pkgname}.desktop ${pkgdir}/usr/share/applications/${_pkgname}.desktop
+ cd $srcdir/$pkgname
+ install -dm755 ${pkgdir}/usr/share/icons/hicolor
+ cp -r icon/* ${pkgdir}/usr/share/icons/hicolor/
+
+ # Binaries
+ install -Dm755 build/sielo-browser ${pkgdir}/usr/bin/sielo-browser
+ install -Dm755 build/SNCompiler/sielo-compiler ${pkgdir}/usr/bin/sielo-compiler
+}
+# vim set: ts=4 sw=4 et
diff --git a/sielo-browser.desktop b/sielo-browser.desktop
new file mode 100644
index 000000000000..73e69defa265
--- /dev/null
+++ b/sielo-browser.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=sielo-browser
+Comment=A simple, customizable and fast web browser
+Exec="/usr/bin/sielo-browser"
+Terminal=false
+Type=Application
+Icon=sielo-browser \ No newline at end of file