summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton2019-05-16 21:14:02 +0300
committerAnton2019-05-16 21:14:02 +0300
commit183a12da8df5c31e49ad1312c11794e47bc94274 (patch)
treea0ec01bf800f7a4ac7bda6e58a01c71f3038d2f4
downloadaur-183a12da8df5c31e49ad1312c11794e47bc94274.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5fa4460440d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = siesta
+ pkgdesc = A first-principles materials simulation code using DFT
+ pkgver = 4.0.2
+ pkgrel = 1
+ url = https://departments.icmab.es/leem/siesta
+ arch = x86_64
+ license = GPL
+ makedepends = sed
+ depends = gcc-fortran
+ depends = openmpi
+ depends = blas
+ depends = lapack
+ depends = scalapack
+ source = https://launchpad.net/siesta/4.0/4.0.2/+download/siesta-4.0.2.tar.gz
+ sha256sums = bafbda19358f0c1dd39bb1253c92ee548791a1c0f648977051d2657216874f7e
+
+pkgname = siesta
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92f52e98086f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Anton Kudelin <kudelin at protonmail dot com>
+
+pkgname=siesta
+pkgver=4.0.2
+pkgrel=1
+pkgdesc="A first-principles materials simulation code using DFT"
+arch=("x86_64")
+url="https://departments.icmab.es/leem/siesta"
+license=('GPL')
+depends=('gcc-fortran' 'openmpi' 'blas' 'lapack' 'scalapack')
+makedepends=('sed')
+source=("https://launchpad.net/$pkgname/4.0/$pkgver/+download/$pkgname-$pkgver.tar.gz")
+sha256sums=('bafbda19358f0c1dd39bb1253c92ee548791a1c0f648977051d2657216874f7e')
+
+build() {
+ cd $pkgname-$pkgver/Obj
+ ../Src/obj_setup.sh
+ ../Src/configure \
+ --prefix=/usr \
+ --enable-mpi \
+ --with-lapack="-llapack" \
+ FCFLAGS="$CFLAGS"
+ make -j1
+ cd ../Util
+ sed -i "s/ make/ make -j1/g" build_all.sh
+ ./build_all.sh
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -dm755 $pkgdir/opt/siesta/bin
+ install -dm755 $pkgdir/usr/{bin,share/siesta}
+ find ./Util -type f ! -name "*.sh" -executable -exec install -m755 {} "$pkgdir/opt/siesta/bin" ";"
+ install -m755 ./Obj/siesta $pkgdir/opt/siesta/bin
+ ln -sf $pkgdir/opt/siesta/bin/siesta $pkgdir/usr/bin
+}