summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJavier Tia2015-09-14 19:45:22 -0600
committerJavier Tia2015-09-14 19:45:22 -0600
commit1d188a4ad73db8cbc0efc419d16753ba8b748374 (patch)
treec13729ec9b8af4e78f0221f5d2c7e352bab1655e
parent56e773bd87c473cf4e4c5efc04f519232c831260 (diff)
downloadaur-1d188a4ad73db8cbc0efc419d16753ba8b748374.tar.gz
Build instead of copy static binaries
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD22
2 files changed, 18 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b710cca6fbb..452b02718ac5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,12 +6,13 @@ pkgbase = sift
arch = i686
arch = x86_64
license = GPL3
+ makedepends = go
+ conflicts = sift-bin
+ replaces = sift-bin
options = !strip
options = !emptydirs
- source_i686 = http://sift-tool.org/downloads/sift/sift_0.3.2_linux_386.tar.gz
- md5sums_i686 = dd4072ab5ec382965185610cccf323d3
- source_x86_64 = http://sift-tool.org/downloads/sift/sift_0.3.2_linux_amd64.tar.gz
- md5sums_x86_64 = a618ba446ac00d5b3d17aef8207ba1a1
+ source = https://github.com/svent/sift/archive/v0.3.2.tar.gz
+ sha256sums = c14025e993f47a947ed9d1b444e3b3f334090428eb25736eae5779b19a764308
pkgname = sift
diff --git a/PKGBUILD b/PKGBUILD
index 2bf95cbfbf4f..ee1554151227 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,20 +6,24 @@ pkgdesc="A fast and powerful open source alternative to grep"
arch=('i686' 'x86_64')
url="http://sift-tool.org/"
license=('GPL3')
+makedepends=('go')
options=('!strip' '!emptydirs')
-source_i686=("http://sift-tool.org/downloads/sift/${pkgname}_${pkgver}_linux_386.tar.gz")
-source_x86_64=("http://sift-tool.org/downloads/sift/${pkgname}_${pkgver}_linux_amd64.tar.gz")
-md5sums_i686=('dd4072ab5ec382965185610cccf323d3')
-md5sums_x86_64=('a618ba446ac00d5b3d17aef8207ba1a1')
+conflicts=('sift-bin')
+replaces=('sift-bin')
+source=("https://github.com/svent/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('c14025e993f47a947ed9d1b444e3b3f334090428eb25736eae5779b19a764308')
-[[ "$CARCH" = "i686" ]] && _debarch='386'
-[[ "$CARCH" = "x86_64" ]] && _debarch='amd64'
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ go build
+}
package() {
- cd "${pkgname}_${pkgver}_linux_${_debarch}"
+ cd "${pkgname}-${pkgver}"
- install -Dm 775 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm 775 "${pkgname}-${pkgver}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
# vim:set ts=2 sw=2 et: