summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2018-08-07 23:00:11 -0400
committerEli Schwartz2018-08-07 23:00:11 -0400
commit179c2cddd5db39a276c1734476ae5823def8de92 (patch)
tree458f48b4ebdfcb8ba238402b3ebd30f3f60c037c
parent744324119766c9aaacbacd2551dcca7ee527a489 (diff)
downloadaur-179c2cddd5db39a276c1734476ae5823def8de92.tar.gz
upgpkg: sigil-git 0.9.10.r11.gf60e9d36-2
upstream release python 3.7 rebuild Add more sigil plugin modules optdepends. As usual these are bundled in the Windows/macOS binary builds, and very commonly used in thirdparty plugins which expect them there by default.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5162ba656013..abdfa83c5347 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sigil-git
pkgdesc = A WYSIWYG ebook editor
- pkgver = 0.9.8.r33.g2cc7fac2
- pkgrel = 1
+ pkgver = 0.9.10.r11.gf60e9d36
+ pkgrel = 2
url = https://github.com/Sigil-Ebook/Sigil
arch = i686
arch = x86_64
@@ -23,6 +23,8 @@ pkgbase = sigil-git
optdepends = python-cssutils: recommended for plugins
optdepends = python-pillow: recommended for plugins
optdepends = python-regex: recommended for plugins
+ optdepends = python-pyqt5: recommended for plugins
+ optdepends = tk: recommended for plugins
provides = sigil
conflicts = sigil
source = sigil::git+https://github.com/Sigil-Ebook/Sigil
diff --git a/PKGBUILD b/PKGBUILD
index 83bcc625755e..1c2a4418be15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,8 @@
_localepurge=
pkgname=sigil-git
-pkgver=0.9.8.r33.g2cc7fac2
-pkgrel=1
+pkgver=0.9.10.r11.gf60e9d36
+pkgrel=2
pkgdesc="A WYSIWYG ebook editor"
arch=('i686' 'x86_64')
url="https://github.com/Sigil-Ebook/Sigil"
@@ -23,7 +23,9 @@ optdepends=('hunspell-en: for English dictionary support'
'python-cssselect: recommended for plugins'
'python-cssutils: recommended for plugins'
'python-pillow: recommended for plugins'
- 'python-regex: recommended for plugins')
+ 'python-regex: recommended for plugins'
+ 'python-pyqt5: recommended for plugins'
+ 'tk: recommended for plugins')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("${pkgname%-git}"::"git+${url}")
@@ -49,6 +51,7 @@ pkgver() {
build() {
mkdir -p "${srcdir}/${pkgname%-git}/build"
cd "${srcdir}/${pkgname%-git}/build"
+
cmake -G "Unix Makefiles" \
-DUSE_SYSTEM_LIBS=1 \
-DSYSTEM_LIBS_REQUIRED=1 \
@@ -56,7 +59,6 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
-DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS}" \
- -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_SKIP_RPATH=ON ..
make
}