summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2016-08-04 12:06:39 -0400
committerEli Schwartz2016-08-04 12:06:39 -0400
commit20f4057c40b90e59096d19e6c40c0ae5397222ed (patch)
tree10fff760c6fd2b110378d0d5069e8e75c2c466f4
parent13f5bfddb9df90a8e02df39f1e02a21b57eb4b91 (diff)
downloadaur-20f4057c40b90e59096d19e6c40c0ae5397222ed.tar.gz
upgpkg: sigil-git 0.9.6.r23.g8e6b153-1
Upstream fix for system dictionaries renders this patch unnecessary.
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Set-environment-variable-for-Sigil-dictionaries.patch52
-rw-r--r--PKGBUILD14
3 files changed, 6 insertions, 66 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 386fa468ecb4..924ba3ef185d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sigil-git
pkgdesc = A WYSIWYG ebook editor
- pkgver = 0.9.6.r1.g8a08e06
- pkgrel = 2
+ pkgver = 0.9.6.r23.g8e6b153
+ pkgrel = 1
url = https://github.com/Sigil-Ebook/Sigil
arch = i686
arch = x86_64
@@ -26,9 +26,7 @@ pkgbase = sigil-git
provides = sigil
conflicts = sigil
source = sigil::git+https://github.com/Sigil-Ebook/Sigil
- source = 0001-Set-environment-variable-for-Sigil-dictionaries.patch
sha256sums = SKIP
- sha256sums = 8a1d6085c1ba2c2a919581096af20d0851a6a7a70c4c001a3d30881a511e52c6
pkgname = sigil-git
diff --git a/0001-Set-environment-variable-for-Sigil-dictionaries.patch b/0001-Set-environment-variable-for-Sigil-dictionaries.patch
deleted file mode 100644
index 7b3bd05c0afe..000000000000
--- a/0001-Set-environment-variable-for-Sigil-dictionaries.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From 5a16d1119dab001cd58492b1bb76a43245e0641f Mon Sep 17 00:00:00 2001
-From: Eli Schwartz <eschwartz93@gmail.com>
-Date: Sat, 24 Oct 2015 20:16:52 -0400
-Subject: [PATCH] Set environment variable for Sigil dictionaries.
-
-Needed to teach Sigil where the system dictionaries are located when not
-using vendored copies. Upstream apparently does NOT want the build
-system to be capable of setting this automatically.
-
-See: https://github.com/Sigil-Ebook/Sigil/pull/139 where I tried to
-rework things to teach Sigil to use the system dictionaries -- and in
-the process have the install script configured *automatically*.
-
-But environment variables are apparently preferred (while keeping the
-vendored location built into the executable).
-The build script was at least taught to stop installing the dictionaries
-via an option (separate from USE_SYSTEM_LIBS) but the aspect of my PR
-which configured the launch script automatically (because the plugin
-launcher *definitely* needs the env var) was not utilized at all.
-
-Per: https://github.com/Sigil-Ebook/Sigil/commit/ce862ebb236721e21a5620eef2e815e70cff9d35
-"They are commonly set by manually editing Sigil's launch script [...]"
-
-I guess this patch will have to do instead.
----
- src/Resource_Files/bash/sigil-sh_install | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/src/Resource_Files/bash/sigil-sh_install b/src/Resource_Files/bash/sigil-sh_install
-index 08fd266..c8287a1 100755
---- a/src/Resource_Files/bash/sigil-sh_install
-+++ b/src/Resource_Files/bash/sigil-sh_install
-@@ -18,6 +18,11 @@ if [ -z "$SIGIL_SHARE_PREFIX" ]; then
- export SIGIL_SHARE_PREFIX
- fi
-
-+# Create an environment var for the system dictionaries location.
-+if [ -z "$SIGIL_DICTIONARIES" ]; then
-+ export SIGIL_DICTIONARIES="/usr/share/hunspell:/usr/share/hyphen"
-+fi
-+
- # Not really needed anymore but left in for fringe cases
- #if [ -z "$SIGIL_EXTRA_ROOT" ]; then
- # SIGIL_EXTRA_ROOT="${SIGIL_SHARE_ROOT}"
-@@ -27,4 +32,3 @@ fi
- export LD_LIBRARY_PATH
-
- exec ${CMAKE_INSTALL_PREFIX}/lib/sigil/sigil "$@"
--
---
-2.6.2
-
diff --git a/PKGBUILD b/PKGBUILD
index 38b8b2eb7eac..65964d592018 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,8 @@
_localepurge=
pkgname=sigil-git
-pkgver=0.9.6.r1.g8a08e06
-pkgrel=2
+pkgver=0.9.6.r23.g8e6b153
+pkgrel=1
pkgdesc="A WYSIWYG ebook editor"
arch=('i686' 'x86_64')
url="https://github.com/Sigil-Ebook/Sigil"
@@ -26,18 +26,12 @@ optdepends=('hunspell-en: for English dictionary support'
'python-regex: recommended for plugins')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("${pkgname%-git}"::"git+${url}"
- "0001-Set-environment-variable-for-Sigil-dictionaries.patch")
-sha256sums=('SKIP'
- '8a1d6085c1ba2c2a919581096af20d0851a6a7a70c4c001a3d30881a511e52c6')
+source=("${pkgname%-git}"::"git+${url}")
+sha256sums=('SKIP')
prepare() {
cd "${srcdir}/${pkgname%-git}"
- # Upstream would prefer we *manually* set this env var when using the
- # build option "-DINSTALL_BUNDLED_DICTS=0"
- patch -p1 < ../0001-Set-environment-variable-for-Sigil-dictionaries.patch
-
if [[ "${_localepurge}" != "" ]]; then
for trans in src/Resource_Files/ts/*; do
if [[ "$(basename $trans | sed -r 's/(_.*)_.*/\1/g')" != "sigil_${_localepurge}" ]]; then