summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2015-10-25 04:33:54 -0400
committerEli Schwartz2015-10-25 04:36:19 -0400
commit66b45ee4a1c88938063533d5b1edb7dcb4b1698c (patch)
tree50dbc9bef77ce05de2b4a38366f8061340ebfe17
parentdd4a206310399a347dad81c5f6430beb4e612270 (diff)
downloadaur-66b45ee4a1c88938063533d5b1edb7dcb4b1698c.tar.gz
upgpkg: sigil-git 0.8.901.r43.g2570281-1
- Debundle hunspell dictionaries. - Add patch to set env var pointing to system hunspell dictionaries.
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Set-environment-variable-for-Sigil-dictionaries.patch52
-rw-r--r--PKGBUILD21
3 files changed, 75 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85433fb893b2..dd535d0664f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sigil-git
pkgdesc = A WYSIWYG ebook editor
- pkgver = 0.8.901.r30.g3959de7
+ pkgver = 0.8.901.r43.g2570281
pkgrel = 1
url = https://github.com/Sigil-Ebook/Sigil
install = sigil.install
@@ -18,6 +18,8 @@ pkgbase = sigil-git
depends = gtk-update-icon-cache
depends = python-lxml
depends = python-six
+ optdepends = hunspell-en: for English dictionary support
+ optdepends = hyphen-en: for English hyphenation support in plugins
optdepends = python-html5lib: recommended for plugins
optdepends = python-chardet: recommended for plugins
optdepends = python-cssselect: recommended for plugins
@@ -27,7 +29,9 @@ pkgbase = sigil-git
provides = sigil
conflicts = sigil
source = sigil::git+https://github.com/Sigil-Ebook/Sigil
- md5sums = SKIP
+ source = 0001-Set-environment-variable-for-Sigil-dictionaries.patch
+ sha256sums = SKIP
+ sha256sums = 94bc03892a30506308c67bba11dc7e9e375447fa1b42f328850771dd80d4df36
pkgname = sigil-git
diff --git a/0001-Set-environment-variable-for-Sigil-dictionaries.patch b/0001-Set-environment-variable-for-Sigil-dictionaries.patch
new file mode 100644
index 000000000000..32d733d7d605
--- /dev/null
+++ b/0001-Set-environment-variable-for-Sigil-dictionaries.patch
@@ -0,0 +1,52 @@
+From 7e4a8770a8a0b011f99dd7d4228915f98f65efba Mon Sep 17 00:00:00 2001
+From: Eli Schwartz <eschwartz93@gmail.com>
+Date: Sat, 24 Oct 2015 20:16:52 -0400
+Subject: [PATCH] Set environment variable for Sigil dictionaries.
+
+Needed to teach Sigil where the system dictionaries are located when not
+using vendored copies. Upstream apparently does NOT want the build
+system to be capable of setting this automatically.
+
+See: https://github.com/Sigil-Ebook/Sigil/pull/139 where I tried to
+rework things to teach Sigil to use the system dictionaries -- and in
+the process have the install script configured *automatically*.
+
+But environment variables are apparently preferred (while keeping the
+vendored location built into the executable).
+The build script was at least taught to stop installing the dictionaries
+via an option (separate from USE_SYSTEM_LIBS) but the aspect of my PR
+which configured the launch script automatically (because the plugin
+launcher *definitely* needs the env var) was not utilized at all.
+
+Per: https://github.com/Sigil-Ebook/Sigil/commit/ce862ebb236721e21a5620eef2e815e70cff9d35
+"They are commonly set by manually editing Sigil's launch script [...]"
+
+I guess this patch will have to do instead.
+---
+ src/Resource_Files/bash/sigil-sh_install | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/src/Resource_Files/bash/sigil-sh_install b/src/Resource_Files/bash/sigil-sh_install
+index 08fd266..1720dfe 100755
+--- a/src/Resource_Files/bash/sigil-sh_install
++++ b/src/Resource_Files/bash/sigil-sh_install
+@@ -18,6 +18,11 @@ if [ -z "$SIGIL_SHARE_PREFIX" ]; then
+ export SIGIL_SHARE_PREFIX
+ fi
+
++# Create an environment var for the Sigil share directory location.
++if [ -z "$SIGIL_DICTIONARIES" ]; then
++ export SIGIL_DICTIONARIES="/usr/share/hunspell:/usr/share/hyphen"
++fi
++
+ # Not really needed anymore but left in for fringe cases
+ #if [ -z "$SIGIL_EXTRA_ROOT" ]; then
+ # SIGIL_EXTRA_ROOT="${SIGIL_SHARE_ROOT}"
+@@ -27,4 +32,3 @@ fi
+ export LD_LIBRARY_PATH
+
+ exec ${CMAKE_INSTALL_PREFIX}/lib/sigil/sigil "$@"
+-
+--
+2.6.2
+
diff --git a/PKGBUILD b/PKGBUILD
index 4b3db1db6781..6d1c47e6b7f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: David Mougey <imapiekindaguy at gmail dot com>
pkgname=sigil-git
-pkgver=0.8.901.r30.g3959de7
+pkgver=0.8.901.r43.g2570281
pkgrel=1
pkgdesc="A WYSIWYG ebook editor"
arch=('i686' 'x86_64')
@@ -11,7 +11,9 @@ license=('GPL3')
depends=('qt5-webkit' 'hunspell' 'desktop-file-utils' 'minizip'
'gtk-update-icon-cache' 'python-lxml' 'python-six')
makedepends=('git' 'qt5-tools' 'qt5-svg' 'cmake')
-optdepends=('python-html5lib: recommended for plugins'
+optdepends=('hunspell-en: for English dictionary support'
+ 'hyphen-en: for English hyphenation support in plugins'
+ 'python-html5lib: recommended for plugins'
'python-chardet: recommended for plugins'
'python-cssselect: recommended for plugins'
'python-cssutils: recommended for plugins'
@@ -20,8 +22,18 @@ optdepends=('python-html5lib: recommended for plugins'
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
install=sigil.install
-source=("${pkgname%-git}"::"git+${url}")
-md5sums=('SKIP')
+source=("${pkgname%-git}"::"git+${url}"
+ "0001-Set-environment-variable-for-Sigil-dictionaries.patch")
+sha256sums=('SKIP'
+ '94bc03892a30506308c67bba11dc7e9e375447fa1b42f328850771dd80d4df36')
+
+prepare() {
+ cd "${srcdir}/${pkgname%-git}"
+
+ # Upstream would prefer we *manually* set this env var when using the
+ # build option "-DINSTALL_BUNDLED_DICTS=0"
+ patch -p1 < ../0001-Set-environment-variable-for-Sigil-dictionaries.patch
+}
pkgver() {
cd "${srcdir}/${pkgname%-git}"
@@ -34,6 +46,7 @@ build() {
cmake -G "Unix Makefiles" \
-DUSE_SYSTEM_LIBS=1 \
-DSYSTEM_LIBS_REQUIRED=1 \
+ -DINSTALL_BUNDLED_DICTS=0 \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
-DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS}" \