summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2015-12-11 16:44:17 -0500
committerEli Schwartz2015-12-11 16:44:17 -0500
commitd4ae18b1883e109662f30b2b5ee768ba128f8ae3 (patch)
tree2379d81aa05eda3fdb2fdfbf8306475f6b8fa4ee
parent66b45ee4a1c88938063533d5b1edb7dcb4b1698c (diff)
downloadaur-d4ae18b1883e109662f30b2b5ee768ba128f8ae3.tar.gz
upgpkg: sigil-git 0.9.1.r40.g449aed1-1
- Force rebuild against new C++11 ABI - option to skip translations (non-standard location isn't friendly with localepurge & friends) - Compile python bytecode
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Set-environment-variable-for-Sigil-dictionaries.patch6
-rw-r--r--PKGBUILD22
3 files changed, 25 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd535d0664f1..29c5096284c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sigil-git
pkgdesc = A WYSIWYG ebook editor
- pkgver = 0.8.901.r43.g2570281
+ pkgver = 0.9.1.r40.g449aed1
pkgrel = 1
url = https://github.com/Sigil-Ebook/Sigil
install = sigil.install
@@ -31,7 +31,7 @@ pkgbase = sigil-git
source = sigil::git+https://github.com/Sigil-Ebook/Sigil
source = 0001-Set-environment-variable-for-Sigil-dictionaries.patch
sha256sums = SKIP
- sha256sums = 94bc03892a30506308c67bba11dc7e9e375447fa1b42f328850771dd80d4df36
+ sha256sums = 8a1d6085c1ba2c2a919581096af20d0851a6a7a70c4c001a3d30881a511e52c6
pkgname = sigil-git
diff --git a/0001-Set-environment-variable-for-Sigil-dictionaries.patch b/0001-Set-environment-variable-for-Sigil-dictionaries.patch
index 32d733d7d605..7b3bd05c0afe 100644
--- a/0001-Set-environment-variable-for-Sigil-dictionaries.patch
+++ b/0001-Set-environment-variable-for-Sigil-dictionaries.patch
@@ -1,4 +1,4 @@
-From 7e4a8770a8a0b011f99dd7d4228915f98f65efba Mon Sep 17 00:00:00 2001
+From 5a16d1119dab001cd58492b1bb76a43245e0641f Mon Sep 17 00:00:00 2001
From: Eli Schwartz <eschwartz93@gmail.com>
Date: Sat, 24 Oct 2015 20:16:52 -0400
Subject: [PATCH] Set environment variable for Sigil dictionaries.
@@ -27,14 +27,14 @@ I guess this patch will have to do instead.
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/src/Resource_Files/bash/sigil-sh_install b/src/Resource_Files/bash/sigil-sh_install
-index 08fd266..1720dfe 100755
+index 08fd266..c8287a1 100755
--- a/src/Resource_Files/bash/sigil-sh_install
+++ b/src/Resource_Files/bash/sigil-sh_install
@@ -18,6 +18,11 @@ if [ -z "$SIGIL_SHARE_PREFIX" ]; then
export SIGIL_SHARE_PREFIX
fi
-+# Create an environment var for the Sigil share directory location.
++# Create an environment var for the system dictionaries location.
+if [ -z "$SIGIL_DICTIONARIES" ]; then
+ export SIGIL_DICTIONARIES="/usr/share/hunspell:/usr/share/hyphen"
+fi
diff --git a/PKGBUILD b/PKGBUILD
index 6d1c47e6b7f3..e10d61dfd0df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,14 @@
# Maintainer: Eli Schwartz <eschwartz93@gmail.com>
# Contributor: David Mougey <imapiekindaguy at gmail dot com>
+# All my PKGBUILDs are managed at https://github.com/eli-schwartz/pkgbuilds
+
+# Set this variable to anything to disable translations.
+# Or specify the two-letter language code of the translation you wish to keep.
+_localepurge=
+
pkgname=sigil-git
-pkgver=0.8.901.r43.g2570281
+pkgver=0.9.1.r40.g449aed1
pkgrel=1
pkgdesc="A WYSIWYG ebook editor"
arch=('i686' 'x86_64')
@@ -25,7 +31,7 @@ install=sigil.install
source=("${pkgname%-git}"::"git+${url}"
"0001-Set-environment-variable-for-Sigil-dictionaries.patch")
sha256sums=('SKIP'
- '94bc03892a30506308c67bba11dc7e9e375447fa1b42f328850771dd80d4df36')
+ '8a1d6085c1ba2c2a919581096af20d0851a6a7a70c4c001a3d30881a511e52c6')
prepare() {
cd "${srcdir}/${pkgname%-git}"
@@ -33,6 +39,14 @@ prepare() {
# Upstream would prefer we *manually* set this env var when using the
# build option "-DINSTALL_BUNDLED_DICTS=0"
patch -p1 < ../0001-Set-environment-variable-for-Sigil-dictionaries.patch
+
+ if [[ "${_localepurge}" != "" ]]; then
+ for trans in src/Resource_Files/ts/*; do
+ if [[ "$(basename $trans | sed -r 's/(_.*)_.*/\1/g')" != "sigil_${_localepurge}" ]]; then
+ rm $trans
+ fi
+ done
+ fi
}
pkgver() {
@@ -63,4 +77,8 @@ package() {
install -D -m 0644 ../src/Resource_Files/icon/app_icon_${_pic}.png \
"${pkgdir}"/usr/share/icons/hicolor/${_pic}x${_pic}/apps/sigil.png
done
+
+ # Compile python bytecode
+ python -m compileall "${pkgdir}"/usr/share/sigil/{plugin_launchers/python/,python3lib}
+ python -O -m compileall "${pkgdir}"/usr/share/sigil/{plugin_launchers/python/,python3lib}
}