summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxwell Pray2016-02-17 19:23:30 -0800
committerMaxwell Pray2016-02-17 19:23:30 -0800
commit7cbf8dac0e5392979faa25e9ba19c86a8dbc9859 (patch)
treefc9c65a2d10061538041b0360e514676d04aa16d
downloadaur-7cbf8dac0e5392979faa25e9ba19c86a8dbc9859.tar.gz
Initial commit.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f02c0096aeb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu Feb 18 03:22:21 UTC 2016
+pkgbase = sigrok-firmware-saleae-logic16
+ pkgdesc = FX2 firmware and the FPGA bitstreams required for using the Saleae Logic16.
+ pkgver = 0
+ pkgrel = 1
+ url = http://sigrok.org/wiki/Saleae_Logic16#Firmware
+ arch = any
+ license = custom
+ makedepends = python
+ source = git://sigrok.org/sigrok-util
+ source = http://downloads.saleae.com/Logic%201.1.15%20(64-bit).zip
+ source = https://trello-attachments.s3.amazonaws.com/55f0a61a10f9f592573a4205/5697d62ba03bdba21581dc15/429ff3e09adc4067ec9984092759897d/License.txt
+ md5sums = SKIP
+ md5sums = a5074f4bf198ebb95b6e08309b207a88
+ md5sums = 58d2dcb368ef3586f50f2333ac89e5ff
+
+pkgname = sigrok-firmware-saleae-logic16
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c43d712179ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Maxwell Pray a.k.a. Synthead <synthead@gmail.com>
+
+pkgname=sigrok-firmware-saleae-logic16
+pkgver=0
+pkgrel=1
+pkgdesc="FX2 firmware and the FPGA bitstreams required for using the Saleae Logic16."
+arch=(any)
+url="http://sigrok.org/wiki/Saleae_Logic16#Firmware"
+license=(custom)
+makedepends=(python)
+source=(
+ "git://sigrok.org/sigrok-util"
+ "http://downloads.saleae.com/Logic%201.1.15%20(64-bit).zip"
+ "https://trello-attachments.s3.amazonaws.com/55f0a61a10f9f592573a4205/5697d62ba03bdba21581dc15/429ff3e09adc4067ec9984092759897d/License.txt")
+md5sums=(
+ "SKIP"
+ "a5074f4bf198ebb95b6e08309b207a88"
+ "58d2dcb368ef3586f50f2333ac89e5ff")
+
+package() {
+ mkdir -p "$pkgdir/usr/share/sigrok-firmware"
+ cd "$pkgdir/usr/share/sigrok-firmware"
+
+ "$srcdir/sigrok-util/firmware/saleae-logic16/sigrok-fwextract-saleae-logic16" "$srcdir/Logic 1.1.15 (64-bit)/Logic"
+
+ install -Dm 644 "$srcdir/License.txt" "$pkgdir/usr/share/licenses/$pkgname/License.txt"
+}