summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2019-12-28 18:32:49 +0300
committerViktor Drobot2019-12-28 18:32:49 +0300
commit854eae6ee39686e0ed0c2d9a7366c039e9a8bf97 (patch)
tree47cc4ee1defe5d2b4e45b3017e9b4eccde4e453b
parentca0a4708d22a416416a627a8b06a24ff953b1fbb (diff)
downloadaur-854eae6ee39686e0ed0c2d9a7366c039e9a8bf97.tar.gz
Move to cmake
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef9a6793a5a5..59fa9b0e791f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = sigutils-git
pkgdesc = Digital signal processing library
- pkgver = r186.4a1e057
+ pkgver = r203.8caefe4
pkgrel = 1
url = https://github.com/BatchDrake/sigutils
arch = any
license = GPL
makedepends = git
- makedepends = autoconf
- makedepends = automake
+ makedepends = cmake>=3.7.2
depends = libsndfile
depends = alsa-lib
+ depends = fftw
+ optdepends = libvolk
provides = sigutils
conflicts = sigutils
+ options = !buildflags
source = sigutils-git::git+https://github.com/BatchDrake/sigutils.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b353a6183f4e..cc048f07a26c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,20 @@
# Contributor: Julio Diez <juliosddr@gmail.com>
pkgname=sigutils-git
-pkgver=r186.4a1e057
+pkgver=r203.8caefe4
pkgrel=1
pkgdesc="Digital signal processing library"
arch=("any")
url="https://github.com/BatchDrake/sigutils"
license=("GPL")
-depends=("libsndfile" "alsa-lib")
-makedepends=("git" "autoconf" "automake")
+depends=("libsndfile" "alsa-lib" "fftw")
+makedepends=("git" "cmake>=3.7.2")
+optdepends=("libvolk")
provides=("sigutils")
conflicts=("sigutils")
source=(${pkgname}::git+https://github.com/BatchDrake/sigutils.git)
md5sums=('SKIP')
+options=('!buildflags')
pkgver() {
cd "${pkgname}"
@@ -23,14 +25,15 @@ pkgver() {
build() {
cd "$pkgname"
- autoreconf -fvi
- ./configure --prefix=/usr
+ mkdir build
+ cd build
+ cmake ..
make
}
package() {
- cd "$pkgname"
+ cd "$pkgname/build"
make DESTDIR="$pkgdir/" install
}