summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClemens Brunner2016-12-20 14:01:49 +0100
committerClemens Brunner2016-12-20 14:01:49 +0100
commitc4e3f5e25441bf69270820d713a43d3b2222c761 (patch)
tree5c62f904bd0e80b7abe893542be72ceef0220f45
downloadaur-c4e3f5e25441bf69270820d713a43d3b2222c761.tar.gz
Initial version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
-rw-r--r--zoom_gui_command.patch13
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b4da15b9a39
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = sigviewer
+ pkgdesc = A biosignal viewer
+ pkgver = 0.5.2
+ pkgrel = 1
+ url = https://github.com/cbrnr/sigviewer
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qt4
+ depends = libbiosig
+ source = https://sourceforge.net/projects/sigviewer/files/0.5.2/sigviewer-0.5.2-src.tar.gz
+ source = zoom_gui_command.patch
+ sha1sums = bc4622c23d7fde98f24bd979b6c61e9f0a2d1627
+ sha1sums = cb023fde0a4e87be137fad514990c966681e63ea
+
+pkgname = sigviewer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0fcbeae67f15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Clemens Brunner <clemens dot brunner at gmail dot com>
+pkgname=sigviewer
+pkgver=0.5.2
+pkgrel=1
+pkgdesc="A biosignal viewer"
+arch=('i686' 'x86_64')
+url="https://github.com/cbrnr/sigviewer"
+license=('GPL')
+groups=()
+depends=('qt4' 'libbiosig')
+makedepends=('')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(https://sourceforge.net/projects/$pkgname/files/$pkgver/$pkgname-$pkgver-src.tar.gz
+ zoom_gui_command.patch)
+noextract=()
+sha1sums=('bc4622c23d7fde98f24bd979b6c61e9f0a2d1627'
+ 'cb023fde0a4e87be137fad514990c966681e63ea')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver-src"
+ patch -p0 < ../../zoom_gui_command.patch
+ qmake-qt4
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ cp "$srcdir/$pkgname-$pkgver-src/bin/release/sigviewer" "$pkgdir/usr/bin"
+}
diff --git a/zoom_gui_command.patch b/zoom_gui_command.patch
new file mode 100644
index 000000000000..c2b1ee726dd1
--- /dev/null
+++ b/zoom_gui_command.patch
@@ -0,0 +1,13 @@
+--- src/gui_impl/commands/zoom_gui_command.h
++++ src/gui_impl/commands/zoom_gui_command.h
+@@ -57,8 +57,8 @@
+ //-------------------------------------------------------------------------
+ float32 minPixelPerSample ();
+
+- static float const ZOOM_FACTOR_ = 2;
+- static float const MAX_HORIZONTAL_ZOOM_IN_ = 32;
++ static int const ZOOM_FACTOR_ = 2;
++ static int const MAX_HORIZONTAL_ZOOM_IN_ = 32;
+
+ static QString const GOTO_;
+ static QString const ZOOM_IN_VERTICAL_;