summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormetamer2016-02-16 23:41:23 -0500
committermetamer2016-02-16 23:41:23 -0500
commit548e979e11cb198350476e6efcf40544b8114e72 (patch)
tree9af5465664f725c553e25c22ed79e822f4bb553f
downloadaur-548e979e11cb198350476e6efcf40544b8114e72.tar.gz
initial import of package from https://github.com/aur-archive/sil
update to v1.3
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD39
-rw-r--r--sil.install7
-rw-r--r--sil.sh3
4 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76bfbc37abe3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Wed Feb 17 04:41:17 UTC 2016
+pkgbase = sil
+ pkgdesc = A game of adventure set in the first age of Middle-earth, when the world still rang with elven song and gleamed with dwarven mail. Walk the dark halls of Angband. Slay creatures black and fell. Wrest a shining Silmaril from Morgoth’s iron crown.
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = http://www.amirrorclear.net/flowers/game/sil/
+ install = sil.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = custom:angband
+ license = custom
+ depends = ncurses
+ depends = libx11
+ source = http://www.amirrorclear.net/flowers/game/sil/Sil-130-src.zip
+ source = sil.sh
+ md5sums = de935f85ab8f9c98d5b781f9ed9e114c
+ md5sums = 0e7223f80877fc6aeed7dbbbb9948d52
+
+pkgname = sil
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ced2abc0215
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: metamer <metamer at openmailbox dot org>
+# Contributor: Michał Walczak <michalwalczak at michalwalczak dot eu>
+
+pkgname=sil
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="A game of adventure set in the first age of Middle-earth, when the world still rang with elven song and gleamed with dwarven mail. Walk the dark halls of Angband. Slay creatures black and fell. Wrest a shining Silmaril from Morgoth’s iron crown."
+arch=('i686' 'x86_64')
+url="http://www.amirrorclear.net/flowers/game/sil/"
+license=('GPL2' 'custom:angband' 'custom')
+depends=('ncurses' 'libx11')
+install=sil.install
+source=(http://www.amirrorclear.net/flowers/game/sil/Sil-130-src.zip
+ 'sil.sh')
+md5sums=('de935f85ab8f9c98d5b781f9ed9e114c'
+ '0e7223f80877fc6aeed7dbbbb9948d52')
+
+build() {
+ cd "$srcdir/Sil/src"
+
+ make -f Makefile.std install
+
+ cd ..
+}
+
+package() {
+ _dest_dir="$pkgdir/usr/share/$pkgname"
+ mkdir -p $_dest_dir
+
+ cd "$srcdir/Sil"
+
+ install -DTm644 "$srcdir/Sil/copying.txt" "${pkgdir}/usr/share/licenses/${pkgname}/copying.txt"
+ install -DTm644 "$srcdir/Sil/Sil 1.3 Manual.pdf" "${pkgdir}/usr/share/${pkgname}/doc/sil-manual.pdf"
+ install -D -m 755 sil "$_dest_dir"
+ cp -r lib "$_dest_dir"
+ chown -R :games $_dest_dir
+ chmod -R 775 $_dest_dir
+ install -T -D -m 755 "$srcdir/sil.sh" "$pkgdir/usr/bin/$pkgname"
+}
diff --git a/sil.install b/sil.install
new file mode 100644
index 000000000000..2907bdf9f33f
--- /dev/null
+++ b/sil.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo "Users that want to play the game should be on group games."
+ echo "Run "sil --help" for commandline options."
+ echo "For example to get multiple windows run:"
+ echo ""sil -mx11 -- -n*" where * is the number of windows"
+ echo ""sil -mgcu" for curses"
+}
diff --git a/sil.sh b/sil.sh
new file mode 100644
index 000000000000..6e4e4c5fa753
--- /dev/null
+++ b/sil.sh
@@ -0,0 +1,3 @@
+cd /usr/share/sil/
+./sil "$@"
+cd - &>/dev/null