summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-08-10 15:08:14 +0300
committerCaleb Maclennan2021-08-10 15:08:14 +0300
commit937746f7be56c88510ec78dba9f4c0a776b78247 (patch)
tree0e815801f4421bc37996ea8fc8fade6cac5ece64
parent5015417e914c11f4afeef4551cb34ee7430a51bf (diff)
downloadaur-937746f7be56c88510ec78dba9f4c0a776b78247.tar.gz
upgpkg: sile-luajit 0.10.15-3
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD72
2 files changed, 40 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30310edb6fec..76af0599d6cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sile-luajit
pkgdesc = Modern typesetting system inspired by TeX
pkgver = 0.10.15
- pkgrel = 2
+ pkgrel = 3
url = https://www.sile-typesetter.org
arch = x86_64
license = MIT
@@ -13,7 +13,9 @@ pkgbase = sile-luajit
depends = icu
depends = libpng
depends = luajit
+ depends = lua51-bit32
depends = lua51-cassowary
+ depends = lua51-compat53
depends = lua51-cosmo
depends = lua51-cliargs
depends = lua51-expat
@@ -43,4 +45,3 @@ pkgbase = sile-luajit
sha256sums = 49b55730effd473c64a8955a903e48f61c51dd7bb862e6d5481193218d1e3c5c
pkgname = sile-luajit
-
diff --git a/PKGBUILD b/PKGBUILD
index 0d37d03f77c7..f9bf526029de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,45 +4,47 @@ _pkgname=sile
pkgname=$_pkgname-luajit
pkgdesc='Modern typesetting system inspired by TeX'
pkgver=0.10.15
-pkgrel=2
-arch=('x86_64')
-url='https://www.sile-typesetter.org'
-license=('MIT')
-_lua_deps=('cassowary'
- 'cosmo'
- 'cliargs'
- 'expat'
- 'filesystem'
- 'linenoise'
- 'lpeg'
- 'luaepnf'
- 'penlight'
- 'repl'
- 'sec'
- 'socket'
- 'stdlib'
- 'utf8'
- 'vstruct'
- 'zlib')
-depends=('fontconfig'
- 'freetype2'
- 'harfbuzz'
- 'gentium-plus-font'
- 'icu'
- 'libpng' # this goes with libtexpdf if ever split out to a library package
- 'luajit'
+pkgrel=3
+arch=(x86_64)
+url=https://www.sile-typesetter.org
+license=(MIT)
+_lua_deps=(bit32 # Upstream Issue: https://github.com/sile-typesetter/sile/issues/1189
+ cassowary
+ compat53 # Not needed for Lua 5.3+, LuaJIT is 5.1(ish)
+ cosmo
+ cliargs
+ expat
+ filesystem
+ linenoise
+ lpeg
+ luaepnf
+ penlight
+ repl
+ sec
+ socket
+ stdlib
+ utf8
+ vstruct
+ zlib)
+depends=(fontconfig
+ freetype2
+ harfbuzz
+ gentium-plus-font
+ icu
+ libpng # this goes with libtexpdf if ever split out to a library package
+ luajit
"${_lua_deps[@]/#/lua51-}"
- 'zlib')
+ zlib)
# Note find via find-deps; needs rebuilding any time versions of these change;
# currently missing several because parent packages are missing the provides=()
-depends+=('libfreetype.so'
- 'libharfbuzz.so'
- 'libicudata.so'
- 'libicui18n.so'
- 'libicuio.so'
- 'libicuuc.so')
+depends+=(libfreetype.so
+ libharfbuzz.so
+ libicudata.so
+ libicui18n.so
+ libicuio.so
+ libicuuc.so)
checkdepends=('poppler')
-provides=('libtexpdf.so'
+provides=(libtexpdf.so
"$_pkgname=$pkgver")
conflicts=("$_pkgname")
source=("https://github.com/sile-typesetter/sile/releases/download/v$pkgver/$_pkgname-$pkgver.tar.xz")