summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-08-14 19:38:30 +0300
committerCaleb Maclennan2020-08-14 19:38:30 +0300
commitda75eea07079629ea15eeb6dbf437c21df6a1135 (patch)
tree95055498a31bfdd120b245d5c9b595491e598f4e
downloadaur-da75eea07079629ea15eeb6dbf437c21df6a1135.tar.gz
Initial upload: sile-luajit 0.10.10-1
-rw-r--r--.SRCINFO45
-rw-r--r--PKGBUILD67
2 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e56a8a264b52
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,45 @@
+pkgbase = sile-luajit
+ pkgdesc = Modern typesetting system inspired by TeX
+ pkgver = 0.10.10
+ pkgrel = 1
+ url = https://www.sile-typesetter.org
+ arch = x86_64
+ license = MIT
+ checkdepends = poppler
+ depends = fontconfig
+ depends = freetype2
+ depends = harfbuzz
+ depends = gentium-plus-font
+ depends = icu
+ depends = libpng
+ depends = luajit
+ depends = lua51-cassowary
+ depends = lua51-cosmo
+ depends = lua51-cliargs
+ depends = lua51-expat
+ depends = lua51-filesystem
+ depends = lua51-linenoise
+ depends = lua51-lpeg
+ depends = lua51-luaepnf
+ depends = lua51-penlight
+ depends = lua51-repl
+ depends = lua51-sec
+ depends = lua51-socket
+ depends = lua51-stdlib
+ depends = lua51-vstruct
+ depends = lua51-zlib
+ depends = zlib
+ depends = libfreetype.so
+ depends = libharfbuzz.so
+ depends = libicudata.so
+ depends = libicui18n.so
+ depends = libicuio.so
+ depends = libicuuc.so
+ provides = libtexpdf.so
+ provides = sile=0.10.10
+ conflicts = sile
+ source = https://github.com/sile-typesetter/sile/releases/download/v0.10.10/sile-0.10.10.tar.xz
+ sha256sums = efc0be18118e20fa5cbde330850b3f65d0835c05a75ad45d4ee85f8ff8f6fe54
+
+pkgname = sile-luajit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23f4c21bb6bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_pkgname=sile
+pkgname=$_pkgname-luajit
+pkgdesc='Modern typesetting system inspired by TeX'
+pkgver=0.10.10
+pkgrel=1
+arch=('x86_64')
+url='https://www.sile-typesetter.org'
+license=('MIT')
+_lua_deps=('cassowary'
+ 'cosmo'
+ 'cliargs'
+ 'expat'
+ 'filesystem'
+ 'linenoise'
+ 'lpeg'
+ 'luaepnf'
+ 'penlight'
+ 'repl'
+ 'sec'
+ 'socket'
+ 'stdlib'
+ 'vstruct'
+ 'zlib')
+depends=('fontconfig'
+ 'freetype2'
+ 'harfbuzz'
+ 'gentium-plus-font'
+ 'icu'
+ 'libpng' # this goes with libtexpdf if ever split out to a library package
+ 'luajit'
+ "${_lua_deps[@]/#/lua51-}"
+ 'zlib')
+# Note find via find-deps; needs rebuilding any time versions of these change;
+# currently missing several because parent packages are missing the provides=()
+depends+=('libfreetype.so'
+ 'libharfbuzz.so'
+ 'libicudata.so'
+ 'libicui18n.so'
+ 'libicuio.so'
+ 'libicuuc.so')
+checkdepends=('poppler')
+provides=('libtexpdf.so'
+ "$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+source=("https://github.com/sile-typesetter/sile/releases/download/v$pkgver/$_pkgname-$pkgver.tar.xz")
+sha256sums=('efc0be18118e20fa5cbde330850b3f65d0835c05a75ad45d4ee85f8ff8f6fe54')
+
+build () {
+ cd "$_pkgname-$pkgver"
+ ./configure \
+ --prefix /usr \
+ --with-luajit \
+ --with-system-luarocks
+ make all
+}
+
+check () {
+ cd "$_pkgname-$pkgver"
+ make check
+}
+
+package () {
+ cd "$_pkgname-$pkgver"
+ make install DESTDIR="$pkgdir"
+}