summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-08-03 17:18:13 +0300
committerCaleb Maclennan2020-08-03 19:49:12 +0300
commit7f2d1ef9345cf6becbc74b5fd9d9f0b90d357b68 (patch)
tree07fb0a02c26bfbc0175d173b1a5591e3a68c9ef4
downloadaur-7f2d1ef9345cf6becbc74b5fd9d9f0b90d357b68.tar.gz
Initial upload: sile-luajit-git 0.10.9.r100.g5f6d689-1
-rw-r--r--.SRCINFO48
-rw-r--r--PKGBUILD86
2 files changed, 134 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f65dd19fc5ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,48 @@
+pkgbase = sile-luajit-git
+ pkgdesc = Modern typesetting system inspired by TeX
+ pkgver = 0.10.9.r100.g5f6d689
+ pkgrel = 1
+ url = https://www.sile-typesetter.org
+ arch = x86_64
+ license = MIT
+ checkdepends = poppler
+ makedepends = git
+ depends = fontconfig
+ depends = freetype2
+ depends = harfbuzz
+ depends = gentium-plus-font
+ depends = icu
+ depends = libpng
+ depends = luajit
+ depends = lua51-cassowary
+ depends = lua51-cosmo
+ depends = lua51-cliargs
+ depends = lua51-expat
+ depends = lua51-filesystem
+ depends = lua51-linenoise
+ depends = lua51-lpeg
+ depends = lua51-luaepnf
+ depends = lua51-penlight
+ depends = lua51-repl
+ depends = lua51-sec
+ depends = lua51-socket
+ depends = lua51-stdlib
+ depends = lua51-vstruct
+ depends = lua51-zlib
+ depends = zlib
+ depends = libfreetype.so
+ depends = libharfbuzz.so
+ depends = libicudata.so
+ depends = libicui18n.so
+ depends = libicuio.so
+ depends = libicuuc.so
+ provides = libtexpdf.so
+ provides = sile=0.10.9.r100.g5f6d689
+ conflicts = sile
+ source = git://github.com/sile-typesetter/sile.git
+ source = git://github.com/sile-typesetter/libtexpdf.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = sile-luajit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..419737aae631
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,86 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
+
+_pkgname=sile
+pkgname=$_pkgname-luajit-git
+pkgdesc='Modern typesetting system inspired by TeX'
+pkgver=0.10.9.r100.g5f6d689
+pkgrel=1
+arch=('x86_64')
+url='https://www.sile-typesetter.org'
+license=('MIT')
+_lua_deps=('cassowary'
+ 'cosmo'
+ 'cliargs'
+ 'expat'
+ 'filesystem'
+ 'linenoise'
+ 'lpeg'
+ 'luaepnf'
+ 'penlight'
+ 'repl'
+ 'sec'
+ 'socket'
+ 'stdlib'
+ 'vstruct'
+ 'zlib')
+depends=('fontconfig'
+ 'freetype2'
+ 'harfbuzz'
+ 'gentium-plus-font'
+ 'icu'
+ 'libpng' # this goes with libtexpdf if ever split out to a library package
+ 'luajit'
+ "${_lua_deps[@]/#/lua51-}"
+ 'zlib')
+# Note find via find-deps; needs rebuilding any time versions of these change;
+# currently missing several because parent packages are missing the provides=()
+depends+=('libfreetype.so'
+ 'libharfbuzz.so'
+ 'libicudata.so'
+ 'libicui18n.so'
+ 'libicuio.so'
+ 'libicuuc.so')
+makedepends=('git')
+checkdepends=('poppler')
+provides=('libtexpdf.so'
+ "$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+source=("git://github.com/sile-typesetter/$_pkgname.git"
+ "git://github.com/sile-typesetter/libtexpdf.git")
+sha256sums=('SKIP' 'SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags --abbrev=7 --match="v*" HEAD |
+ sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare () {
+ cd "$_pkgname"
+ git submodule init
+ git config submodule.libtexpdf.url "$srcdir/libtexpdf"
+ git submodule update
+ ./bootstrap.sh
+}
+
+build () {
+ cd "$_pkgname"
+ ./configure \
+ --prefix /usr \
+ --docdir /usr/share/doc/$pkgname \
+ --with-luajit \
+ --with-system-luarocks
+ make all
+}
+
+check () {
+ cd "$_pkgname"
+ make check
+}
+
+package () {
+ cd "$_pkgname"
+ make install DESTDIR="$pkgdir"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
+}