summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-08-12 13:33:05 +0300
committerCaleb Maclennan2021-08-12 13:33:05 +0300
commita816f6f6b13c7dd4b23f8e618a0df780dc8f334d (patch)
tree88e30f8cc6fe502236686c45402cc8215bc1641f
parent067c33356623dcc043138d5f0509b3d735d59e1b (diff)
downloadaur-a816f6f6b13c7dd4b23f8e618a0df780dc8f334d.tar.gz
upgpkg: sile-luajit-git 0.10.15.r65.g7e77f89-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD118
2 files changed, 64 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 835394e31519..f8c7c399f196 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sile-luajit-git
pkgdesc = Modern typesetting system inspired by TeX
- pkgver = 0.10.14.r0.g175595a
+ pkgver = 0.10.15.r65.g7e77f89
pkgrel = 1
url = https://www.sile-typesetter.org
arch = x86_64
@@ -14,7 +14,9 @@ pkgbase = sile-luajit-git
depends = icu
depends = libpng
depends = luajit
+ depends = lua51-bit32
depends = lua51-cassowary
+ depends = lua51-compat53
depends = lua51-cosmo
depends = lua51-cliargs
depends = lua51-expat
@@ -38,7 +40,7 @@ pkgbase = sile-luajit-git
depends = libicuio.so
depends = libicuuc.so
provides = libtexpdf.so
- provides = sile=0.10.14.r0.g175595a
+ provides = sile=0.10.15.r65.g7e77f89
conflicts = sile
source = git://github.com/sile-typesetter/sile.git
source = git://github.com/sile-typesetter/libtexpdf.git
@@ -46,4 +48,3 @@ pkgbase = sile-luajit-git
sha256sums = SKIP
pkgname = sile-luajit-git
-
diff --git a/PKGBUILD b/PKGBUILD
index ba785e01c30b..19d29d1d298e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,47 +4,49 @@
_pkgname=sile
pkgname=$_pkgname-luajit-git
pkgdesc='Modern typesetting system inspired by TeX'
-pkgver=0.10.14.r0.g175595a
+pkgver=0.10.15.r65.g7e77f89
pkgrel=1
-arch=('x86_64')
-url='https://www.sile-typesetter.org'
-license=('MIT')
-_lua_deps=('cassowary'
- 'cosmo'
- 'cliargs'
- 'expat'
- 'filesystem'
- 'linenoise'
- 'lpeg'
- 'luaepnf'
- 'penlight'
- 'repl'
- 'sec'
- 'socket'
- 'stdlib'
- 'utf8'
- 'vstruct'
- 'zlib')
-depends=('fontconfig'
- 'freetype2'
- 'harfbuzz'
- 'gentium-plus-font'
- 'icu'
- 'libpng' # this goes with libtexpdf if ever split out to a library package
- 'luajit'
+arch=(x86_64)
+url=https://www.sile-typesetter.org
+license=(MIT)
+_lua_deps=(bit32 # Upstream Issue: https://github.com/sile-typesetter/sile/issues/1189
+ cassowary
+ compat53 # Not needed for Lua 5.3+, LuaJIT is 5.1(ish)
+ cosmo
+ cliargs
+ expat
+ filesystem
+ linenoise
+ lpeg
+ luaepnf
+ penlight
+ repl
+ sec
+ socket
+ stdlib
+ utf8
+ vstruct
+ zlib)
+depends=(fontconfig
+ freetype2
+ harfbuzz
+ gentium-plus-font
+ icu
+ libpng # this goes with libtexpdf if ever split out to a library package
+ luajit
"${_lua_deps[@]/#/lua51-}"
- 'zlib')
-# Note find via find-deps; needs rebuilding any time versions of these change;
+ zlib)
+# Note: find via find-deps; needs rebuilding any time versions of these change;
# currently missing several because parent packages are missing the provides=()
-depends+=('libfreetype.so'
- 'libharfbuzz.so'
- 'libicudata.so'
- 'libicui18n.so'
- 'libicuio.so'
- 'libicuuc.so')
-makedepends=('git')
-checkdepends=('poppler')
-provides=('libtexpdf.so'
+depends+=(libfreetype.so
+ libharfbuzz.so
+ libicudata.so
+ libicui18n.so
+ libicuio.so
+ libicuuc.so)
+makedepends=(git)
+checkdepends=(poppler)
+provides=(libtexpdf.so
"$_pkgname=$pkgver")
conflicts=("$_pkgname")
source=("git://github.com/sile-typesetter/$_pkgname.git"
@@ -53,36 +55,36 @@ sha256sums=('SKIP'
'SKIP')
pkgver() {
- cd "$_pkgname"
- git describe --long --tags --abbrev=7 --match="v*" HEAD |
- sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$_pkgname"
+ git describe --long --tags --abbrev=7 --match="v*" HEAD |
+ sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare () {
- cd "$_pkgname"
- git submodule init
- git config submodule.libtexpdf.url "$srcdir/libtexpdf"
- git submodule update
- ./bootstrap.sh
+ cd "$_pkgname"
+ git submodule init
+ git config submodule.libtexpdf.url "$srcdir/libtexpdf"
+ git submodule update
+ ./bootstrap.sh
}
build () {
- cd "$_pkgname"
- ./configure \
- --prefix /usr \
- --docdir /usr/share/doc/$pkgname \
- --with-luajit \
- --with-system-luarocks
- make all
+ cd "$_pkgname"
+ ./configure \
+ --prefix /usr \
+ --docdir /usr/share/doc/$pkgname \
+ --with-luajit \
+ --with-system-luarocks
+ make all
}
check () {
- cd "$_pkgname"
- make check
+ cd "$_pkgname"
+ make check
}
package () {
- cd "$_pkgname"
- make install DESTDIR="$pkgdir"
- mv "$pkgdir/usr/share/licenses/"{sile,$pkgname}
+ cd "$_pkgname"
+ make install DESTDIR="$pkgdir"
+ mv "$pkgdir/usr/share/licenses/"{$_pkgname,$pkgname}
}