summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Keenan2015-06-08 17:57:26 -0700
committerColin Keenan2015-06-08 17:57:26 -0700
commit6b7654ab6b11ef18e7373dbea71272abaabcbd15 (patch)
treec28fcc37fa26bc9c894b15059291e8ec20812ba3
downloadaur-6b7654ab6b11ef18e7373dbea71272abaabcbd15.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD29
-rw-r--r--silentcast.install18
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d9ce8f981ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = silentcast
+ pkgdesc = Silent Screencast: video record your screen and make it into an animated gif
+ pkgver = 2.0
+ pkgrel = 3
+ url = https://github.com/colinkeenan/silentcast
+ install = silentcast.install
+ arch = any
+ license = GPL
+ depends = bash
+ depends = ffmpeg
+ depends = imagemagick
+ depends = xdotool
+ depends = xorg-xrandr
+ depends = xorg-xwininfo
+ depends = wmctrl
+ depends = python-gobject
+ depends = python-cairo
+ depends = xdg-utils
+ depends = yad
+ source = https://github.com/colinkeenan/silentcast/archive/v2.0.tar.gz
+ md5sums = 4638cb6349efd807050df35e1f0a192f
+
+pkgname = silentcast
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db4e28ba57ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Colin Keenan <colinnkeenan at gmail dot com>
+
+pkgname=silentcast
+pkgver=2.0
+pkgrel=3
+pkgdesc="Silent Screencast: video record your screen and make it into an animated gif"
+arch=('any')
+url="https://github.com/colinkeenan/silentcast"
+license=('GPL')
+depends=('bash' 'ffmpeg' 'imagemagick' 'xdotool' 'xorg-xrandr' 'xorg-xwininfo' 'wmctrl' 'python-gobject' 'python-cairo' 'xdg-utils' 'yad')
+install=${pkgname}.install
+
+source=($url"/archive/v"$pkgver".tar.gz")
+md5sums=('4638cb6349efd807050df35e1f0a192f')
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -D -m755 silentcast "$pkgdir/usr/bin/silentcast"
+ install -D -m755 genffcom "$pkgdir/usr/bin/genffcom"
+ install -D -m755 temptoanim "$pkgdir/usr/bin/temptoanim"
+ install -D -m755 transparent_window.py "$pkgdir/usr/share/silentcast/transparent_window.py"
+ install -m755 unity_indicator.py "$pkgdir/usr/share/silentcast"
+ install -m644 stop?.png "$pkgdir/usr/share/silentcast"
+ install -D -m644 silentcast.png "$pkgdir/usr/share/pixmaps/silentcast.png"
+ install -D -m644 silentcast.desktop "$pkgdir/usr/share/applications/silentcast.desktop"
+ install -D -m644 README.md "$pkgdir/usr/share/doc/silentcast/README.md"
+ install -m644 *png "$pkgdir/usr/share/doc/silentcast"
+ install -m644 *gif "$pkgdir/usr/share/doc/silentcast"
+}
diff --git a/silentcast.install b/silentcast.install
new file mode 100644
index 000000000000..294221f3c9c1
--- /dev/null
+++ b/silentcast.install
@@ -0,0 +1,18 @@
+# colored makepkg-like function
+note() {
+ printf "${BLUE}==>${ALL_OFF}${YELLOW} NOTE:${ALL_OFF}${BOLD} ${1}${ALL_OFF}\n"
+}
+
+ALL_OFF="$(tput sgr0)"
+BOLD="$(tput bold)"
+BLUE="${BOLD}$(tput setaf 4)"
+YELLOW="${BOLD}$(tput setaf 3)"
+
+post_install() {
+ note "The command is 'silentcast'. See /usr/share/doc/silentcast/README.md or https://github.com/colinkeenan/silentcast/#silentcast for full instructions and tips."
+}
+
+
+post_upgrade() {
+ post_install
+}