summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarat Moustafine2016-10-25 00:45:07 +0300
committerMarat Moustafine2016-10-25 00:45:07 +0300
commit63a8d324c450056d7f4b66d2e066330adb5caca7 (patch)
tree057318645c68f6f6dcd0d501ae37a1dd6f4447a0
downloadaur-63a8d324c450056d7f4b66d2e066330adb5caca7.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ad68c459577
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = silicon-git
+ pkgdesc = A high performance, middleware oriented C++14 http web framework
+ pkgver = 0.1+11+gfc46119
+ pkgrel = 1
+ url = https://github.com/matt-42/silicon
+ arch = any
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ optdepends = iod: for introspection of objects and generation code matching their data structures
+ optdepends = libmicrohttpd: for microhttpd backend
+ provides = silicon
+ conflicts = silicon
+ source = git+https://github.com/matt-42/silicon.git
+ sha256sums = SKIP
+
+pkgname = silicon-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..287346ced6dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Marat Moustafine <m-dash-moustafine-at-yandex-dot-ru>
+
+_pkgname=silicon
+pkgname=$_pkgname-git
+pkgver=0.1+11+gfc46119
+pkgrel=1
+pkgdesc='A high performance, middleware oriented C++14 http web framework'
+arch=('any')
+url='https://github.com/matt-42/silicon'
+license=('MIT')
+makedepends=('cmake' 'git')
+optdepends=('iod: for introspection of objects and generation code matching their data structures'
+ 'libmicrohttpd: for microhttpd backend')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=(git+$url.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --long --tags | sed -r 's/^v//;s/-/+/g'
+}
+
+build () {
+ cd $_pkgname
+ mkdir -p build
+
+ cd build
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ ..
+ make
+}
+
+package() {
+ cd $_pkgname
+ install -D -m644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+ cd build
+ make DESTDIR=$pkgdir install
+}