summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneodarz2020-11-11 12:00:31 +0100
committerneodarz2020-11-11 12:00:31 +0100
commit234d209749d1cb22ea8871daec9df39f98ff1a7b (patch)
tree440773fe9461db7160898b21ee01fa03cb027b1f
parentc60a348cd22dc8ff2b2b21db467a17187f4f54b5 (diff)
downloadaur-234d209749d1cb22ea8871daec9df39f98ff1a7b.tar.gz
Update to last version
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06dd863bdabd..a5cf046e7d4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = silkaj
pkgdesc = Powerfull, lightweight, and multi-platform command line client written with Python for Duniter’s currencies
- pkgver = 0.7.6
+ pkgver = 0.8.0
pkgrel = 1
url = https://git.duniter.org/clients/python/silkaj
arch = any
@@ -14,8 +14,10 @@ pkgbase = silkaj
depends = python-tabulate
depends = python-pynacl
depends = python-duniterpy
- source = https://git.duniter.org/clients/python/silkaj/-/archive/v0.7.6/silkaj-v0.7.6.tar.gz
- sha512sums = 69074ddf804d79a2780bb757d0fcab8c08ec63478b215b842e536327348e4a02369b69e5c07b61dbf6245b4cf99847b583b4be853b469503ad1688aaf4732656
+ depends = python-pypeg2
+ depends = python-pylibscrypt
+ source = https://git.duniter.org/clients/python/silkaj/-/archive/v0.8.0/silkaj-v0.8.0.tar.gz
+ sha512sums = 68a30f03aa8420dbec89fee3aa52bb8d061ef05291516f5873a8d50f5dd7c78dbe5827e41ee710854ebd08a7ddaea572adceaff0a3040134295cb24f6c545b99
pkgname = silkaj
diff --git a/PKGBUILD b/PKGBUILD
index b4b72a0c1fd3..7a34232408bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=silkaj
-pkgver=0.7.6
+pkgver=0.8.0
pkgrel=1
pkgdesc="Powerfull, lightweight, and multi-platform command line client written with Python for Duniter’s currencies"
@@ -14,7 +14,12 @@ depends=('python' 'python-setuptools' 'python-dephell' 'python-click' 'python-ip
'python-duniterpy' 'python-pypeg2' 'python-pylibscrypt')
source=("https://git.duniter.org/clients/python/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
-sha512sums=('69074ddf804d79a2780bb757d0fcab8c08ec63478b215b842e536327348e4a02369b69e5c07b61dbf6245b4cf99847b583b4be853b469503ad1688aaf4732656')
+sha512sums=('68a30f03aa8420dbec89fee3aa52bb8d061ef05291516f5873a8d50f5dd7c78dbe5827e41ee710854ebd08a7ddaea572adceaff0a3040134295cb24f6c545b99')
+
+prepare() {
+ cd "$pkgname-v$pkgver"
+ dephell deps convert --from pyproject.toml --to setup.py
+}
package() {
cd "$pkgname-v$pkgver"