summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneodarz2019-10-06 16:37:56 +0200
committerneodarz2019-10-06 16:37:56 +0200
commit91bd8004f68997c799c14926c264d2159b44a7e5 (patch)
treee9c33cf2f48e1a53519efcc78e3843b0370631e6
downloadaur-91bd8004f68997c799c14926c264d2159b44a7e5.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD22
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f8f41a3cb4ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = silkaj
+ pkgdesc = Powerfull, lightweight, and multi-platform command line client written with Python for Duniter’s currencies
+ pkgver = 0.7.3
+ pkgrel = 1
+ url = https://git.duniter.org/clients/python/silkaj
+ arch = any
+ license = GPL3
+ depends = python
+ depends = python-click
+ depends = python-ipaddress
+ depends = python-texttable
+ depends = python-tabulate
+ depends = python-pynacl
+ provides = duniterpy
+ source = https://git.duniter.org/clients/python/silkaj/-/archive/0.7.3/silkaj-v0.7.3.tar.gz
+ sha1sums = 9ea958666a86c9e2c83953d2685c456b72628e67
+
+pkgname = silkaj
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83b1add613a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: neodarz <neodarz at neodarz dot net>
+
+pkgname=silkaj
+
+pkgver=0.7.3
+pkgrel=1
+pkgdesc="Powerfull, lightweight, and multi-platform command line client written with Python for Duniter’s currencies"
+
+url='https://git.duniter.org/clients/python/silkaj'
+arch=('any')
+license=('GPL3')
+
+provides=('duniterpy')
+depends=('python' 'python-click' 'python-ipaddress' 'python-texttable' 'python-tabulate' 'python-pynacl')
+
+source=("https://git.duniter.org/clients/python/$pkgname/-/archive/$pkgver/$pkgname-v$pkgver.tar.gz")
+sha1sums=('9ea958666a86c9e2c83953d2685c456b72628e67')
+
+package() {
+ cd $pkgname-v$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+}