summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneodarz2020-05-21 15:57:30 +0200
committerneodarz2020-05-21 15:57:30 +0200
commitac3b033558202b11052578be68d6cb9a484638de (patch)
treecc155a319caad1a471e7e9319e99c0cb4fee8413
parent91bd8004f68997c799c14926c264d2159b44a7e5 (diff)
downloadaur-ac3b033558202b11052578be68d6cb9a484638de.tar.gz
Update to last version
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8f41a3cb4ac..b00a34139378 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
pkgbase = silkaj
pkgdesc = Powerfull, lightweight, and multi-platform command line client written with Python for Duniter’s currencies
- pkgver = 0.7.3
+ pkgver = 0.7.6
pkgrel = 1
url = https://git.duniter.org/clients/python/silkaj
arch = any
license = GPL3
depends = python
+ depends = python-setuptools
+ depends = python-dephell
depends = python-click
depends = python-ipaddress
depends = python-texttable
depends = python-tabulate
depends = python-pynacl
provides = duniterpy
- source = https://git.duniter.org/clients/python/silkaj/-/archive/0.7.3/silkaj-v0.7.3.tar.gz
- sha1sums = 9ea958666a86c9e2c83953d2685c456b72628e67
+ source = https://git.duniter.org/clients/python/silkaj/-/archive/v0.7.6/silkaj-v0.7.6.tar.gz
+ sha512sums = 69074ddf804d79a2780bb757d0fcab8c08ec63478b215b842e536327348e4a02369b69e5c07b61dbf6245b4cf99847b583b4be853b469503ad1688aaf4732656
pkgname = silkaj
diff --git a/PKGBUILD b/PKGBUILD
index 83b1add613a6..fb1fd95e9360 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=silkaj
-pkgver=0.7.3
+pkgver=0.7.6
pkgrel=1
pkgdesc="Powerfull, lightweight, and multi-platform command line client written with Python for Duniter’s currencies"
@@ -11,12 +11,12 @@ arch=('any')
license=('GPL3')
provides=('duniterpy')
-depends=('python' 'python-click' 'python-ipaddress' 'python-texttable' 'python-tabulate' 'python-pynacl')
+depends=('python' 'python-setuptools' 'python-dephell' 'python-click' 'python-ipaddress' 'python-texttable' 'python-tabulate' 'python-pynacl')
-source=("https://git.duniter.org/clients/python/$pkgname/-/archive/$pkgver/$pkgname-v$pkgver.tar.gz")
-sha1sums=('9ea958666a86c9e2c83953d2685c456b72628e67')
+source=("https://git.duniter.org/clients/python/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
+sha512sums=('69074ddf804d79a2780bb757d0fcab8c08ec63478b215b842e536327348e4a02369b69e5c07b61dbf6245b4cf99847b583b4be853b469503ad1688aaf4732656')
package() {
- cd $pkgname-v$pkgver
+ cd "$pkgname-v$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
}