summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven-Hendrik Haase2017-05-23 19:39:53 +0200
committerSven-Hendrik Haase2017-05-23 19:40:55 +0200
commit17b125a854714a21a17b6c4c3568f1a48f8cf8a4 (patch)
treeaf7af5abdf117f0eef505eb273ff8cf069e690aa
downloadaur-17b125a854714a21a17b6c4c3568f1a48f8cf8a4.tar.gz
Move silly from [community]
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
-rw-r--r--silly-libpng1.5.patch14
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dbe1dfc32aec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = silly
+ pkgdesc = Simple Image Loading LibrarY, a part of the CEGUI project
+ pkgver = 0.1.0
+ pkgrel = 7
+ url = http://www.cegui.org.uk/wiki/index.php/SILLY
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = libjpeg
+ depends = libpng
+ depends = gcc-libs
+ source = http://downloads.sourceforge.net/crayzedsgui/SILLY-0.1.0.tar.gz
+ source = silly-libpng1.5.patch
+ md5sums = c3721547fced7792a36ffc9ce6ec23fd
+ md5sums = 530551c2942aea6fa20f10d06f1e604f
+
+pkgname = silly
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50873c51531f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 148464 2015-12-05 15:21:48Z bpiotrowski $
+# Maintainer: Eric Belanger <eric@archlinux.org>
+# Contributor: G_Syme <demichan(at)mail(dot)upb(dot)de>
+
+pkgname=silly
+pkgver=0.1.0
+pkgrel=7
+pkgdesc="Simple Image Loading LibrarY, a part of the CEGUI project"
+arch=('i686' 'x86_64')
+url="http://www.cegui.org.uk/wiki/index.php/SILLY"
+license=('MIT')
+depends=('libjpeg' 'libpng' 'gcc-libs')
+source=(http://downloads.sourceforge.net/crayzedsgui/SILLY-${pkgver}.tar.gz
+ silly-libpng1.5.patch)
+md5sums=('c3721547fced7792a36ffc9ce6ec23fd'
+ '530551c2942aea6fa20f10d06f1e604f')
+
+build() {
+ cd "${srcdir}/SILLY-${pkgver}"
+
+ patch -Np1 < $srcdir/silly-libpng1.5.patch
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/SILLY-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}
diff --git a/silly-libpng1.5.patch b/silly-libpng1.5.patch
new file mode 100644
index 000000000000..0b2d27252b58
--- /dev/null
+++ b/silly-libpng1.5.patch
@@ -0,0 +1,14 @@
+ILLY-0.1.0/src/loaders/SILLYPNGImageLoader.cpp~ SILLY-0.1.0/src/loaders/SILLYPNGImageLoader.cpp
+--- SILLY-0.1.0/src/loaders/SILLYPNGImageLoader.cpp~ 2006-06-19 00:42:12.000000000 +0200
++++ SILLY-0.1.0/src/loaders/SILLYPNGImageLoader.cpp 2011-12-06 14:38:31.738251526 +0100
+@@ -64,10 +64,7 @@ void PNG_error_function(png_structp png_
+ png_const_charp error)
+ {
+ // printf("PNG Error: %s\n", error);
+- // copied from libpng's pngerror.cpp
+- jmp_buf buf;
+- memcpy(buf, png_ptr->jmpbuf, sizeof(jmp_buf));
+- longjmp(buf, 1);
++ png_longjmp(png_ptr, 1);
+ }
+