summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2018-06-08 10:07:11 -0300
committerRafael Fontenelle2018-06-08 10:09:23 -0300
commit8f8ea6ac9a3ab5775e599ae4d2a606f281bb9c48 (patch)
treeabd6b6c4fec6cfb6f0856cb49461057b183469aa
parent17b125a854714a21a17b6c4c3568f1a48f8cf8a4 (diff)
downloadaur-8f8ea6ac9a3ab5775e599ae4d2a606f281bb9c48.tar.gz
Cosmetic changes
Move patch to prepare(), drop i686 support, and other minor stuff
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD30
2 files changed, 18 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dbe1dfc32aec..4e7a9c848e48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = silly
pkgdesc = Simple Image Loading LibrarY, a part of the CEGUI project
pkgver = 0.1.0
- pkgrel = 7
+ pkgrel = 8
url = http://www.cegui.org.uk/wiki/index.php/SILLY
- arch = i686
arch = x86_64
license = MIT
depends = libjpeg
@@ -11,8 +10,8 @@ pkgbase = silly
depends = gcc-libs
source = http://downloads.sourceforge.net/crayzedsgui/SILLY-0.1.0.tar.gz
source = silly-libpng1.5.patch
- md5sums = c3721547fced7792a36ffc9ce6ec23fd
- md5sums = 530551c2942aea6fa20f10d06f1e604f
+ sha256sums = afa064f70433008ec9837fb601c8d73e73db07856e4566f8bee010758c5304ac
+ sha256sums = 674e86ad0180ceb57e589234a80ac8ed9344357676259349da00c1d23bde264e
pkgname = silly
diff --git a/PKGBUILD b/PKGBUILD
index 50873c51531f..527bf49d015e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,30 +4,30 @@
pkgname=silly
pkgver=0.1.0
-pkgrel=7
+pkgrel=8
pkgdesc="Simple Image Loading LibrarY, a part of the CEGUI project"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.cegui.org.uk/wiki/index.php/SILLY"
license=('MIT')
depends=('libjpeg' 'libpng' 'gcc-libs')
-source=(http://downloads.sourceforge.net/crayzedsgui/SILLY-${pkgver}.tar.gz
- silly-libpng1.5.patch)
-md5sums=('c3721547fced7792a36ffc9ce6ec23fd'
- '530551c2942aea6fa20f10d06f1e604f')
+source=("http://downloads.sourceforge.net/crayzedsgui/SILLY-$pkgver.tar.gz"
+ "silly-libpng1.5.patch")
+sha256sums=('afa064f70433008ec9837fb601c8d73e73db07856e4566f8bee010758c5304ac'
+ '674e86ad0180ceb57e589234a80ac8ed9344357676259349da00c1d23bde264e')
-build() {
- cd "${srcdir}/SILLY-${pkgver}"
-
- patch -Np1 < $srcdir/silly-libpng1.5.patch
+prepare() {
+ cd SILLY-$pkgver
+ patch -Np1 -i "$srcdir/silly-libpng1.5.patch"
+}
+build() {
+ cd SILLY-$pkgver
./configure --prefix=/usr
make
}
package() {
- cd "${srcdir}/SILLY-${pkgver}"
-
- make DESTDIR="${pkgdir}" install
-
- install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ cd SILLY-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -D -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}