summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Kudelin2021-11-25 00:52:06 +0200
committerAnton Kudelin2021-11-25 00:52:06 +0200
commit363538cf64d7853a7a68d3db452bba1258f0e1e5 (patch)
tree875d185f68951d4dead18b1c9c97bf0321868116
parentf5060eadea1fd4ffca542837275e83f5e4881ac4 (diff)
downloadaur-363538cf64d7853a7a68d3db452bba1258f0e1e5.tar.gz
updpkg: 4.11
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
-rw-r--r--hdf5.patch44
-rw-r--r--qt5.patch140
-rw-r--r--remove-mpiposix.patch38
5 files changed, 59 insertions, 198 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fe7596e0390..319d61e480f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,18 @@
pkgbase = silo
pkgdesc = A Mesh and Field I/O Library and Scientific Database
- pkgver = 4.10.2
- pkgrel = 10
+ pkgver = 4.11
+ pkgrel = 1
url = https://wci.llnl.gov/simulation/computer-codes/silo
arch = x86_64
license = BSD
makedepends = gcc-fortran
depends = qt5-base
depends = hdf5-openmpi
- source = https://wci.llnl.gov/content/assets/docs/simulation/computer-codes/silo/silo-4.10.2/silo-4.10.2-bsd.tar.gz
- source = remove-mpiposix.patch
+ source = https://wci.llnl.gov/sites/wci/files/2021-09/silo-4.11-bsd.tgz
source = skip-test.patch
- source = qt5.patch
- sha256sums = 4b901dfc1eb4656e83419a6fde15a2f6c6a31df84edfad7f1dc296e01b20140e
- sha256sums = 824be92ba71e8d797c5836545c58c2c67de0f296b69e8efd9cb9e8ae206837b8
+ source = hdf5.patch
+ sha256sums = 6d0a85a079d48fcdcc0084ecb5fc4cfdcc64852edee780c60cb244d16f4bc4ec
sha256sums = 83e50ccad8477ae7549ae68ab12b180e268e1f28b589b699090dbefb59f57e8b
- sha256sums = 7928c311e238f4d53176f69b75d8099d786b4526fa81fc6c6f565b04c80d5915
+ sha256sums = 8acf1a54c3ba21699a9f1cd67aabc806643630e80795bcf9524f7eb874116bb5
pkgname = silo
-
diff --git a/PKGBUILD b/PKGBUILD
index f60cfac5b6ed..d16b824c5d78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,29 @@
-# Maintainer: Anton Kudelin <kudelin at protonmail dot com>
+# Maintainer: Anton Kudelin <kudelin at protonmail dot com>
# Contributor: eolianoe <eolianoe [at] gmail [DoT] com>
# Contributor: Carl Rogers <carl.rogers@gmail.com>
# Contributor: Jed Brown <jed@59A2.org>
# Contributor: Brenden Mervin <bmervin@utk.edu>
pkgname=silo
-pkgver=4.10.2
-pkgrel=10
+pkgver=4.11
+pkgrel=1
pkgdesc="A Mesh and Field I/O Library and Scientific Database"
url="https://wci.llnl.gov/simulation/computer-codes/silo"
arch=('x86_64')
depends=('qt5-base' 'hdf5-openmpi')
makedepends=('gcc-fortran')
license=('BSD')
-source=("https://wci.llnl.gov/content/assets/docs/simulation/computer-codes/$pkgname/$pkgname-$pkgver/$pkgname-$pkgver-bsd.tar.gz"
- "remove-mpiposix.patch"
+source=("https://wci.llnl.gov/sites/wci/files/2021-09/$pkgname-$pkgver-bsd.tgz"
"skip-test.patch"
- "qt5.patch")
-sha256sums=('4b901dfc1eb4656e83419a6fde15a2f6c6a31df84edfad7f1dc296e01b20140e'
- '824be92ba71e8d797c5836545c58c2c67de0f296b69e8efd9cb9e8ae206837b8'
+ "hdf5.patch")
+sha256sums=('6d0a85a079d48fcdcc0084ecb5fc4cfdcc64852edee780c60cb244d16f4bc4ec'
'83e50ccad8477ae7549ae68ab12b180e268e1f28b589b699090dbefb59f57e8b'
- '7928c311e238f4d53176f69b75d8099d786b4526fa81fc6c6f565b04c80d5915')
+ '8acf1a54c3ba21699a9f1cd67aabc806643630e80795bcf9524f7eb874116bb5')
prepare() {
cd "$srcdir/$pkgname-$pkgver-bsd"
- patch -p0 < "$srcdir/remove-mpiposix.patch"
+ patch -p0 < ../hdf5.patch
patch -p0 < "$srcdir/skip-test.patch"
- patch -p0 < "$srcdir/qt5.patch"
sed -i 's@rocket_silo.lo@rocket_silo.lo ../src/libsiloh5.la@' tests/Makefile.in
}
@@ -43,6 +40,7 @@ build() {
--with-Qt-include-dir=/usr/include/qt \
--with-szlib=/usr/lib \
--with-zlib=/usr/include,/usr/lib \
+ CFLAGS="$CFLAGS -Wno-error=format-security" \
CXXFLAGS="-I/usr/include/qt/QtWidgets $CXXFLAGS -fPIC" \
FFLAGS="$FFLAGS -fallow-argument-mismatch" \
LIBS='-L/usr/lib/openmpi -lmpi -lQt5Core -lQt5Gui -lQt5Widgets'
diff --git a/hdf5.patch b/hdf5.patch
new file mode 100644
index 000000000000..3a518475021e
--- /dev/null
+++ b/hdf5.patch
@@ -0,0 +1,44 @@
+--- src/hdf5_drv/H5FDsilo.c 2021-09-11 01:22:52.000000000 +0300
++++ src/hdf5_drv/H5FDsilo.c 2021-11-25 00:37:06.685422949 +0200
+@@ -252,13 +252,13 @@
+ snprintf(msg, sizeof(msg), Msg "(errno=%d, \"%s\")", \
+ Errno, strerror(Errno)); \
+ ret_value = Ret; \
+- H5Epush_ret(Func, Cls, Maj, Min, msg, Ret) \
++ H5Epush_ret(Func, Cls, Maj, Min, msg, Ret); \
+ }
+ #else
+ #define H5E_PUSH_HELPER(Func,Cls,Maj,Min,Msg,Ret,Errno) \
+ { \
+ ret_value = Ret; \
+- H5Epush_ret(Func, Cls, Maj, Min, Msg, Ret) \
++ H5Epush_ret(Func, Cls, Maj, Min, Msg, Ret); \
+ }
+ #endif
+
+@@ -1355,7 +1355,7 @@
+ assert(sizeof(hsize_t)<=8);
+ memcpy(p, &file->block_size, sizeof(hsize_t));
+ if (H5Tconvert(H5T_NATIVE_HSIZE, H5T_STD_U64LE, 1, buf+8, NULL, H5P_DEFAULT)<0)
+- H5Epush_ret(func, H5E_ERR_CLS, H5E_DATATYPE, H5E_CANTCONVERT, "can't convert superblock info", -1)
++ H5Epush_ret(func, H5E_ERR_CLS, H5E_DATATYPE, H5E_CANTCONVERT, "can't convert superblock info", -1);
+
+ return 0;
+ }
+@@ -1383,14 +1383,14 @@
+
+ /* Make sure the name/version number is correct */
+ if (strcmp(name, "LLNLsilo"))
+- H5Epush_ret(func, H5E_ERR_CLS, H5E_FILE, H5E_BADVALUE, "invalid silo superblock", -1)
++ H5Epush_ret(func, H5E_ERR_CLS, H5E_FILE, H5E_BADVALUE, "invalid silo superblock", -1);
+
+ buf += 8;
+ /* Decode block size */
+ assert(sizeof(hsize_t)<=8);
+ memcpy(x, buf, 8);
+ if (H5Tconvert(H5T_STD_U64LE, H5T_NATIVE_HSIZE, 1, x, NULL, H5P_DEFAULT)<0)
+- H5Epush_ret(func, H5E_ERR_CLS, H5E_DATATYPE, H5E_CANTCONVERT, "can't convert superblock info", -1)
++ H5Epush_ret(func, H5E_ERR_CLS, H5E_DATATYPE, H5E_CANTCONVERT, "can't convert superblock info", -1);
+ ap = (hsize_t*)x;
+ /*file->block_size = *ap; ignore stored value for now */
+
diff --git a/qt5.patch b/qt5.patch
deleted file mode 100644
index 8b43520dc39a..000000000000
--- a/qt5.patch
+++ /dev/null
@@ -1,140 +0,0 @@
-diff --color -Naur silex/main.cpp silex/main.cpp
---- tools/silex/main.cpp 2020-12-11 18:03:35.497787357 +0300
-+++ tools/silex/main.cpp 2020-12-11 18:03:50.058496239 +0300
-@@ -58,7 +58,7 @@
- #include <cstdlib>
-
- #ifndef Q_WS_MACX
--#include "qwindowsstyle.h"
-+#include "qproxystyle.h"
- #endif
- #include "qfiledialog.h"
- #include "qstring.h"
-@@ -91,7 +91,7 @@
- QApplication::setColorSpec(QApplication::ManyColor);
- QApplication a(argc, argv);
- #ifndef Q_WS_MACX
-- a.setStyle(new QWindowsStyle);
-+ a.setStyle(new QProxyStyle);
- #endif
- Explorer *w = 0;
- if (argc > 1)
-diff --color -Naur silex/SiloFile.cpp silex/SiloFile.cpp
---- tools/silex/SiloFile.cpp 2020-12-11 18:03:35.497787357 +0300
-+++ tools/silex/SiloFile.cpp 2020-12-11 18:03:50.058496239 +0300
-@@ -97,7 +97,7 @@
- int drt = DBGetDriverType(db);
- if (canCallFreeCompression[drt] && DBFreeCompressionResources(db,0) == -1)
- canCallFreeCompression[drt] = false;
-- DBSetDir(db, (const char*)path.toAscii());
-+ DBSetDir(db, (const char*)path.toUtf8());
- DBtoc *toc = DBGetToc(db);
-
- int i;
-@@ -204,7 +204,7 @@
- // ****************************************************************************
- SiloFile::SiloFile(const QString &name)
- {
-- db = DBOpen((const char*)name.toAscii(), DB_UNKNOWN, DB_READ);
-+ db = DBOpen((const char*)name.toUtf8(), DB_UNKNOWN, DB_READ);
- if (db)
- root = new SiloDir(db, "/", "/");
- else
-@@ -247,47 +247,47 @@
- void*
- SiloFile::GetVar(const QString &name)
- {
-- return DBGetVar(db, (const char*)name.toAscii());
-+ return DBGetVar(db, (const char*)name.toUtf8());
- }
-
- int
- SiloFile::GetVarType(const QString &name)
- {
-- return DBGetVarType(db, (const char*)name.toAscii());
-+ return DBGetVarType(db, (const char*)name.toUtf8());
- }
-
- int
- SiloFile::GetVarLength(const QString &name)
- {
-- return DBGetVarLength(db, (const char*)name.toAscii());
-+ return DBGetVarLength(db, (const char*)name.toUtf8());
- }
-
- DBobject*
- SiloFile::GetObject(const QString &name)
- {
-- return DBGetObject(db, (const char*)name.toAscii());
-+ return DBGetObject(db, (const char*)name.toUtf8());
- }
-
- void*
- SiloFile::GetComponent(const QString &oname, const QString &cname)
- {
-- return DBGetComponent(db, (const char*)oname.toAscii(), (const char*)cname.toAscii());
-+ return DBGetComponent(db, (const char*)oname.toUtf8(), (const char*)cname.toUtf8());
- }
-
- int
- SiloFile::GetComponentType(const QString &oname, const QString &cname)
- {
-- return DBGetComponentType(db, (const char*)oname.toAscii(), (const char*)cname.toAscii());
-+ return DBGetComponentType(db, (const char*)oname.toUtf8(), (const char*)cname.toUtf8());
- }
-
- DBObjectType
- SiloFile::InqVarType(const QString &name)
- {
-- return DBInqVarType(db, (const char*)name.toAscii());
-+ return DBInqVarType(db, (const char*)name.toUtf8());
- }
-
- bool
- SiloFile::InqVarExists(const QString &name)
- {
-- return DBInqVarExists(db, (const char*)name.toAscii());
-+ return DBInqVarExists(db, (const char*)name.toUtf8());
- }
-diff --color -Naur silex/SiloObjectView.cpp silex/SiloObjectView.cpp
---- tools/silex/SiloObjectView.cpp 2020-12-11 18:03:35.497787357 +0300
-+++ tools/silex/SiloObjectView.cpp 2020-12-11 18:03:50.058496239 +0300
-@@ -177,8 +177,8 @@
- void *comp = silo->GetComponent(name, compname);
- if (!comp)
- {
-- const char *asciiname = name.toAscii();
-- const char *asciicomp = compname.toAscii();
-+ const char *asciiname = name.toUtf8();
-+ const char *asciicomp = compname.toUtf8();
- std::cerr << "ERROR: DBGetComponent failed for object '"
- << asciiname
- <<"', component '"
-@@ -230,11 +230,11 @@
- break;
- default:
- typestr = "var";
-- std::string valStr = std::string(pdbname.toAscii());
-+ std::string valStr = std::string(pdbname.toUtf8());
- if (pdbname.indexOf("'<s>") == 0)
- {
- int len = pdbname.length();
-- valStr = std::string((const char*)(pdbname.toAscii()),4,len-5);
-+ valStr = std::string((const char*)(pdbname.toUtf8()),4,len-5);
- }
- sprintf(value, "%s", valStr.c_str());
- break;
-diff --color -Naur silex/SiloView.cpp silex/SiloView.cpp
---- tools/silex/SiloView.cpp 2020-12-11 18:03:35.497787357 +0300
-+++ tools/silex/SiloView.cpp 2020-12-11 18:03:50.058496239 +0300
-@@ -109,8 +109,8 @@
- dirTreeView->OpenRootDir();
- dirView->Set(silo->root);
-
-- dirTreeView->header()->setResizeMode(QHeaderView::Interactive);
-- dirView->header()->setResizeMode(QHeaderView::Interactive);
-+ dirTreeView->header()->setSectionResizeMode(QHeaderView::Interactive);
-+ dirView->header()->setSectionResizeMode(QHeaderView::Interactive);
- }
- }
-
diff --git a/remove-mpiposix.patch b/remove-mpiposix.patch
deleted file mode 100644
index ca611e3a335e..000000000000
--- a/remove-mpiposix.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- src/hdf5_drv/silo_hdf5.c
-+++ src/hdf5_drv/silo_hdf5.c
-@@ -4717,16 +4717,7 @@ db_hdf5_process_file_options(opts_set_id
-
- /* default HDF5 mpi drivers */
- case DB_FILE_OPTS_H5_DEFAULT_MPIP:
-- {
--#ifdef H5_HAVE_PARALLEL
-- h5status |= H5Pset_fapl_mpiposix(retval, MPI_COMM_SELF, TRUE);
--#else
-- H5Pclose(retval);
-- return db_perror("HDF5 MPI VFD", E_NOTENABLEDINBUILD, me);
--#endif
-- break;
-- }
--
-+ /* FALLTHROUGH */
- case DB_FILE_OPTS_H5_DEFAULT_MPIO:
- {
- #ifdef H5_HAVE_PARALLEL
-@@ -4963,15 +4954,8 @@ db_hdf5_process_file_options(opts_set_id
- if (p = DBGetOption(opts, DBOPT_H5_MPIP_NO_GPFS_HINTS))
- use_gpfs_hints = FALSE;
-
-- if (vfd == DB_H5VFD_MPIO)
-- {
-- h5status |= H5Pset_fapl_mpio(retval, mpi_comm, mpi_info);
-- if (created_info) MPI_Info_free(&mpi_info);
-- }
-- else
-- {
-- h5status |= H5Pset_fapl_mpiposix(retval, mpi_comm, use_gpfs_hints);
-- }
-+ h5status |= H5Pset_fapl_mpio(retval, mpi_comm, mpi_info);
-+ if (created_info) MPI_Info_free(&mpi_info);
- #else
- H5Pclose(retval);
- return db_perror("HDF5 MPI VFD", E_NOTENABLEDINBUILD, me);