summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreolianoe2016-01-30 15:22:27 +0100
committereolianoe2016-01-30 15:22:27 +0100
commit5d73ca6b4bbbb75ee2fc519cd5c6f5f31dc0b8d5 (patch)
tree85060e37f222f8347e717c6dc920889fbcab2f9e
parent60deeb5bd5b59516cffafd0018a92b5439542139 (diff)
downloadaur-5d73ca6b4bbbb75ee2fc519cd5c6f5f31dc0b8d5.tar.gz
Disable hdf5 when using mpi version of hdf5
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD47
2 files changed, 35 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1474d9604aa7..0e14e31835ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sat Jan 30 14:21:16 UTC 2016
pkgbase = silo
pkgdesc = A Mesh and Field I/O Library and Scientific Database
pkgver = 4.10.2
- pkgrel = 2
+ pkgrel = 3
url = https://wci.llnl.gov/simulation/computer-codes/silo
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 6ba83d46495b..ec6ba9414515 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=silo
pkgver=4.10.2
-pkgrel=2
+pkgrel=3
pkgdesc="A Mesh and Field I/O Library and Scientific Database"
url="https://wci.llnl.gov/simulation/computer-codes/silo"
arch=('i686' 'x86_64')
@@ -29,20 +29,37 @@ build() {
cd "${srcdir}/build"
export PYTHON=/usr/bin/python2
- ../${pkgname}-${pkgver}/configure \
- --prefix=/usr \
- --enable-shared --enable-optimization \
- --enable-fortran --enable-browser \
- --enable-silex \
- --with-Qt-dir= --with-Qt-include-dir=/usr/include/qt4 \
- --with-Qt-bin-dir=/usr/lib/qt4/bin --with-Qt-lib-dir=/usr/lib \
- --with-Qt-lib="{QtCore,QtGui}" \
- --with-zlib=/usr/include,/usr/lib \
- --with-hdf5=/usr/include,/usr/lib \
- --enable-pythonmodule \
- --with-szlib=/usr/lib \
- --enable-install-lite-headers \
- --enable-hzip --enable-fpzip
+ if [ "$(pacman -Qs hdf- | grep -o mpi)" == "mpi" ]
+ then
+ ../${pkgname}-${pkgver}/configure \
+ --prefix=/usr \
+ --enable-shared --enable-optimization \
+ --enable-fortran --enable-browser \
+ --enable-silex \
+ --with-Qt-dir= --with-Qt-include-dir=/usr/include/qt4 \
+ --with-Qt-bin-dir=/usr/lib/qt4/bin --with-Qt-lib-dir=/usr/lib \
+ --with-Qt-lib="{QtCore,QtGui}" \
+ --with-zlib=/usr/include,/usr/lib \
+ --enable-pythonmodule \
+ --with-szlib=/usr/lib \
+ --enable-install-lite-headers \
+ --enable-hzip --enable-fpzip
+ else
+ ../${pkgname}-${pkgver}/configure \
+ --prefix=/usr \
+ --enable-shared --enable-optimization \
+ --enable-fortran --enable-browser \
+ --enable-silex \
+ --with-Qt-dir= --with-Qt-include-dir=/usr/include/qt4 \
+ --with-Qt-bin-dir=/usr/lib/qt4/bin --with-Qt-lib-dir=/usr/lib \
+ --with-Qt-lib="{QtCore,QtGui}" \
+ --with-zlib=/usr/include,/usr/lib \
+ --with-hdf5=/usr/include,/usr/lib \
+ --enable-pythonmodule \
+ --with-szlib=/usr/lib \
+ --enable-install-lite-headers \
+ --enable-hzip --enable-fpzip
+ fi
make
}