summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora.kudelin2020-12-11 19:31:50 +0300
committera.kudelin2020-12-11 19:31:50 +0300
commitf5060eadea1fd4ffca542837275e83f5e4881ac4 (patch)
treea637a88b490af7c259876db4cce3243281e8b925
parent22d8515f64339df02ce5c9b3b3138505f65ef19a (diff)
downloadaur-f5060eadea1fd4ffca542837275e83f5e4881ac4.tar.gz
Qt4 -> Qt5, disabled python2
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD100
-rw-r--r--qt5.patch140
-rw-r--r--remove-mpiposix.patch (renamed from silo-4.10.2-remove-mpiposix.patch)8
-rw-r--r--silo-4.10.2-rocket-test.patch11
-rw-r--r--skip-test.patch (renamed from silo-4.10.2-skip-test.patch)6
6 files changed, 199 insertions, 91 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0becca80e142..9fe7596e0390 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,21 @@
pkgbase = silo
pkgdesc = A Mesh and Field I/O Library and Scientific Database
pkgver = 4.10.2
- pkgrel = 9
+ pkgrel = 10
url = https://wci.llnl.gov/simulation/computer-codes/silo
- arch = i686
arch = x86_64
license = BSD
- license = custom
makedepends = gcc-fortran
- depends = qt4
- depends = python2
- depends = hdf5
- source = https://wci.llnl.gov/content/assets/docs/simulation/computer-codes/silo/silo-4.10.2/silo-4.10.2.tar.gz
- source = silo-4.10.2-rocket-test.patch
- source = silo-4.10.2-skip-test.patch
- source = silo-4.10.2-remove-mpiposix.patch
- sha256sums = 3af87e5f0608a69849c00eb7c73b11f8422fa36903dd14610584506e7f68e638
- sha256sums = d66a7a47c4dbb3be20fe3d35275a38de7e23c7b6d7927627255f7a5d49aefb47
- sha256sums = 836b1ca692a07e4354bd52bca85587284086fc89c8cb6c0842f4616008d95c9c
- sha256sums = 64a3c49eb6032dbd2bd0bbbe8110dea77d1d8a99379d96eca15c6b7c0a6f658e
+ depends = qt5-base
+ depends = hdf5-openmpi
+ source = https://wci.llnl.gov/content/assets/docs/simulation/computer-codes/silo/silo-4.10.2/silo-4.10.2-bsd.tar.gz
+ source = remove-mpiposix.patch
+ source = skip-test.patch
+ source = qt5.patch
+ sha256sums = 4b901dfc1eb4656e83419a6fde15a2f6c6a31df84edfad7f1dc296e01b20140e
+ sha256sums = 824be92ba71e8d797c5836545c58c2c67de0f296b69e8efd9cb9e8ae206837b8
+ sha256sums = 83e50ccad8477ae7549ae68ab12b180e268e1f28b589b699090dbefb59f57e8b
+ sha256sums = 7928c311e238f4d53176f69b75d8099d786b4526fa81fc6c6f565b04c80d5915
pkgname = silo
diff --git a/PKGBUILD b/PKGBUILD
index e4cec2c9e9e8..f60cfac5b6ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,80 +1,64 @@
-# Maintainer: eolianoe <eolianoe [at] gmail [DoT] com>
+# Maintainer: Anton Kudelin <kudelin at protonmail dot com>
+# Contributor: eolianoe <eolianoe [at] gmail [DoT] com>
# Contributor: Carl Rogers <carl.rogers@gmail.com>
# Contributor: Jed Brown <jed@59A2.org>
# Contributor: Brenden Mervin <bmervin@utk.edu>
pkgname=silo
pkgver=4.10.2
-pkgrel=9
+pkgrel=10
pkgdesc="A Mesh and Field I/O Library and Scientific Database"
url="https://wci.llnl.gov/simulation/computer-codes/silo"
-arch=('i686' 'x86_64')
-depends=('qt4' 'python2' 'hdf5')
+arch=('x86_64')
+depends=('qt5-base' 'hdf5-openmpi')
makedepends=('gcc-fortran')
-license=('BSD' 'custom')
-source=("https://wci.llnl.gov/content/assets/docs/simulation/computer-codes/${pkgname}/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz"
- "${pkgname}-${pkgver}-rocket-test.patch"
- "${pkgname}-${pkgver}-skip-test.patch"
- "${pkgname}-${pkgver}-remove-mpiposix.patch")
-sha256sums=('3af87e5f0608a69849c00eb7c73b11f8422fa36903dd14610584506e7f68e638'
- 'd66a7a47c4dbb3be20fe3d35275a38de7e23c7b6d7927627255f7a5d49aefb47'
- '836b1ca692a07e4354bd52bca85587284086fc89c8cb6c0842f4616008d95c9c'
- '64a3c49eb6032dbd2bd0bbbe8110dea77d1d8a99379d96eca15c6b7c0a6f658e')
-
-prepare(){
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- patch tests/Makefile.in < "${srcdir}/${pkgname}-${pkgver}-rocket-test.patch"
- # Skip some failing tests
- patch tests/testsuite.at < "${srcdir}/${pkgname}-${pkgver}-skip-test.patch"
-
- # Patch to use extra/hdf5-openmpi, from
- # https://sources.debian.net/src/silo-llnl/4.10.2-5/debian/patches/remove-mpiposix.patch/
- patch src/hdf5_drv/silo_hdf5.c < "${srcdir}/${pkgname}-${pkgver}-remove-mpiposix.patch"
+license=('BSD')
+source=("https://wci.llnl.gov/content/assets/docs/simulation/computer-codes/$pkgname/$pkgname-$pkgver/$pkgname-$pkgver-bsd.tar.gz"
+ "remove-mpiposix.patch"
+ "skip-test.patch"
+ "qt5.patch")
+sha256sums=('4b901dfc1eb4656e83419a6fde15a2f6c6a31df84edfad7f1dc296e01b20140e'
+ '824be92ba71e8d797c5836545c58c2c67de0f296b69e8efd9cb9e8ae206837b8'
+ '83e50ccad8477ae7549ae68ab12b180e268e1f28b589b699090dbefb59f57e8b'
+ '7928c311e238f4d53176f69b75d8099d786b4526fa81fc6c6f565b04c80d5915')
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver-bsd"
+ patch -p0 < "$srcdir/remove-mpiposix.patch"
+ patch -p0 < "$srcdir/skip-test.patch"
+ patch -p0 < "$srcdir/qt5.patch"
+ sed -i 's@rocket_silo.lo@rocket_silo.lo ../src/libsiloh5.la@' tests/Makefile.in
}
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- export PYTHON=/usr/bin/python2
- export CXXFLAGS="${CXXFLAGS} -std=c++98"
+ cd "$srcdir/$pkgname-$pkgver-bsd"
./configure \
- --prefix=/usr \
- --enable-shared --enable-optimization \
- --enable-fortran --enable-browser \
- --enable-silex \
- --with-Qt-dir= --with-Qt-include-dir=/usr/include/qt4 \
- --with-Qt-bin-dir=/usr/lib/qt4/bin --with-Qt-lib-dir=/usr/lib \
- --with-Qt-lib="{QtCore,QtGui}" \
- --with-zlib=/usr/include,/usr/lib \
- --with-hdf5=/usr/include,/usr/lib \
- --enable-pythonmodule \
- --with-szlib=/usr/lib \
- --enable-install-lite-headers \
- --enable-hzip --enable-fpzip
-
+ --prefix=/usr \
+ --enable-shared \
+ --enable-optimization \
+ --enable-silex \
+ --enable-install-lite-headers \
+ --with-x \
+ --with-hdf5=/usr/include,/usr/lib \
+ --with-Qt-include-dir=/usr/include/qt \
+ --with-szlib=/usr/lib \
+ --with-zlib=/usr/include,/usr/lib \
+ CXXFLAGS="-I/usr/include/qt/QtWidgets $CXXFLAGS -fPIC" \
+ FFLAGS="$FFLAGS -fallow-argument-mismatch" \
+ LIBS='-L/usr/lib/openmpi -lmpi -lQt5Core -lQt5Gui -lQt5Widgets'
make
}
check(){
- cd "${srcdir}/${pkgname}-${pkgver}/tests"
-
- export PYTHON=/usr/bin/python2
- export BROWSER="${srcdir}/${pkgname}-${pkgver}/tools/browser"
- make check
+ cd "$srcdir/$pkgname-$pkgver-bsd"
+ make check CXXFLAGS="$CXXFLAGS -std=c++98"
}
package(){
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- make DESTDIR="${pkgdir}" install
-
- make DESTDIR="${pkgdir}" install-html
- install -Dm644 "${srcdir}/${pkgname}-${pkgver}/docs/Silo.book.pdf" \
- "${pkgdir}/usr/share/doc/${pkgname}/Silo.book.pdf"
-
- cd "${srcdir}/${pkgname}-${pkgver}"
- install -Dm644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 BSD_LICENSE_README "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-BSD"
+ cd "$srcdir/$pkgname-$pkgver-bsd"
+ make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install-html
+ install -Dm644 "$srcdir/$pkgname-$pkgver-bsd/docs/Silo.book.pdf" \
+ "$pkgdir/usr/share/doc/$pkgname/Silo.book.pdf"
+ install -Dm644 COPYRIGHT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
diff --git a/qt5.patch b/qt5.patch
new file mode 100644
index 000000000000..8b43520dc39a
--- /dev/null
+++ b/qt5.patch
@@ -0,0 +1,140 @@
+diff --color -Naur silex/main.cpp silex/main.cpp
+--- tools/silex/main.cpp 2020-12-11 18:03:35.497787357 +0300
++++ tools/silex/main.cpp 2020-12-11 18:03:50.058496239 +0300
+@@ -58,7 +58,7 @@
+ #include <cstdlib>
+
+ #ifndef Q_WS_MACX
+-#include "qwindowsstyle.h"
++#include "qproxystyle.h"
+ #endif
+ #include "qfiledialog.h"
+ #include "qstring.h"
+@@ -91,7 +91,7 @@
+ QApplication::setColorSpec(QApplication::ManyColor);
+ QApplication a(argc, argv);
+ #ifndef Q_WS_MACX
+- a.setStyle(new QWindowsStyle);
++ a.setStyle(new QProxyStyle);
+ #endif
+ Explorer *w = 0;
+ if (argc > 1)
+diff --color -Naur silex/SiloFile.cpp silex/SiloFile.cpp
+--- tools/silex/SiloFile.cpp 2020-12-11 18:03:35.497787357 +0300
++++ tools/silex/SiloFile.cpp 2020-12-11 18:03:50.058496239 +0300
+@@ -97,7 +97,7 @@
+ int drt = DBGetDriverType(db);
+ if (canCallFreeCompression[drt] && DBFreeCompressionResources(db,0) == -1)
+ canCallFreeCompression[drt] = false;
+- DBSetDir(db, (const char*)path.toAscii());
++ DBSetDir(db, (const char*)path.toUtf8());
+ DBtoc *toc = DBGetToc(db);
+
+ int i;
+@@ -204,7 +204,7 @@
+ // ****************************************************************************
+ SiloFile::SiloFile(const QString &name)
+ {
+- db = DBOpen((const char*)name.toAscii(), DB_UNKNOWN, DB_READ);
++ db = DBOpen((const char*)name.toUtf8(), DB_UNKNOWN, DB_READ);
+ if (db)
+ root = new SiloDir(db, "/", "/");
+ else
+@@ -247,47 +247,47 @@
+ void*
+ SiloFile::GetVar(const QString &name)
+ {
+- return DBGetVar(db, (const char*)name.toAscii());
++ return DBGetVar(db, (const char*)name.toUtf8());
+ }
+
+ int
+ SiloFile::GetVarType(const QString &name)
+ {
+- return DBGetVarType(db, (const char*)name.toAscii());
++ return DBGetVarType(db, (const char*)name.toUtf8());
+ }
+
+ int
+ SiloFile::GetVarLength(const QString &name)
+ {
+- return DBGetVarLength(db, (const char*)name.toAscii());
++ return DBGetVarLength(db, (const char*)name.toUtf8());
+ }
+
+ DBobject*
+ SiloFile::GetObject(const QString &name)
+ {
+- return DBGetObject(db, (const char*)name.toAscii());
++ return DBGetObject(db, (const char*)name.toUtf8());
+ }
+
+ void*
+ SiloFile::GetComponent(const QString &oname, const QString &cname)
+ {
+- return DBGetComponent(db, (const char*)oname.toAscii(), (const char*)cname.toAscii());
++ return DBGetComponent(db, (const char*)oname.toUtf8(), (const char*)cname.toUtf8());
+ }
+
+ int
+ SiloFile::GetComponentType(const QString &oname, const QString &cname)
+ {
+- return DBGetComponentType(db, (const char*)oname.toAscii(), (const char*)cname.toAscii());
++ return DBGetComponentType(db, (const char*)oname.toUtf8(), (const char*)cname.toUtf8());
+ }
+
+ DBObjectType
+ SiloFile::InqVarType(const QString &name)
+ {
+- return DBInqVarType(db, (const char*)name.toAscii());
++ return DBInqVarType(db, (const char*)name.toUtf8());
+ }
+
+ bool
+ SiloFile::InqVarExists(const QString &name)
+ {
+- return DBInqVarExists(db, (const char*)name.toAscii());
++ return DBInqVarExists(db, (const char*)name.toUtf8());
+ }
+diff --color -Naur silex/SiloObjectView.cpp silex/SiloObjectView.cpp
+--- tools/silex/SiloObjectView.cpp 2020-12-11 18:03:35.497787357 +0300
++++ tools/silex/SiloObjectView.cpp 2020-12-11 18:03:50.058496239 +0300
+@@ -177,8 +177,8 @@
+ void *comp = silo->GetComponent(name, compname);
+ if (!comp)
+ {
+- const char *asciiname = name.toAscii();
+- const char *asciicomp = compname.toAscii();
++ const char *asciiname = name.toUtf8();
++ const char *asciicomp = compname.toUtf8();
+ std::cerr << "ERROR: DBGetComponent failed for object '"
+ << asciiname
+ <<"', component '"
+@@ -230,11 +230,11 @@
+ break;
+ default:
+ typestr = "var";
+- std::string valStr = std::string(pdbname.toAscii());
++ std::string valStr = std::string(pdbname.toUtf8());
+ if (pdbname.indexOf("'<s>") == 0)
+ {
+ int len = pdbname.length();
+- valStr = std::string((const char*)(pdbname.toAscii()),4,len-5);
++ valStr = std::string((const char*)(pdbname.toUtf8()),4,len-5);
+ }
+ sprintf(value, "%s", valStr.c_str());
+ break;
+diff --color -Naur silex/SiloView.cpp silex/SiloView.cpp
+--- tools/silex/SiloView.cpp 2020-12-11 18:03:35.497787357 +0300
++++ tools/silex/SiloView.cpp 2020-12-11 18:03:50.058496239 +0300
+@@ -109,8 +109,8 @@
+ dirTreeView->OpenRootDir();
+ dirView->Set(silo->root);
+
+- dirTreeView->header()->setResizeMode(QHeaderView::Interactive);
+- dirView->header()->setResizeMode(QHeaderView::Interactive);
++ dirTreeView->header()->setSectionResizeMode(QHeaderView::Interactive);
++ dirView->header()->setSectionResizeMode(QHeaderView::Interactive);
+ }
+ }
+
diff --git a/silo-4.10.2-remove-mpiposix.patch b/remove-mpiposix.patch
index 08d30f87689d..ca611e3a335e 100644
--- a/silo-4.10.2-remove-mpiposix.patch
+++ b/remove-mpiposix.patch
@@ -1,7 +1,5 @@
-Index: silo-llnl-4.9.1/src/hdf5_drv/silo_hdf5.c
-===================================================================
---- silo-llnl-4.9.1.orig/src/hdf5_drv/silo_hdf5.c
-+++ silo-llnl-4.9.1/src/hdf5_drv/silo_hdf5.c
+--- src/hdf5_drv/silo_hdf5.c
++++ src/hdf5_drv/silo_hdf5.c
@@ -4717,16 +4717,7 @@ db_hdf5_process_file_options(opts_set_id
/* default HDF5 mpi drivers */
@@ -37,4 +35,4 @@ Index: silo-llnl-4.9.1/src/hdf5_drv/silo_hdf5.c
+ if (created_info) MPI_Info_free(&mpi_info);
#else
H5Pclose(retval);
- return db_perror("HDF5 MPI VFD", E_NOTENABLEDINBUILD, me); \ No newline at end of file
+ return db_perror("HDF5 MPI VFD", E_NOTENABLEDINBUILD, me);
diff --git a/silo-4.10.2-rocket-test.patch b/silo-4.10.2-rocket-test.patch
deleted file mode 100644
index 5ead8d1f5f45..000000000000
--- a/silo-4.10.2-rocket-test.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- tests/Makefile.in 2016-02-26 11:12:34.740074384 +0100
-+++ tests/Makefile.in.new 2016-02-26 11:12:19.389838836 +0100
-@@ -172,7 +172,7 @@
- $(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
- $(ioperf_stdio_la_LDFLAGS) $(LDFLAGS) -o $@
- rocket_silo_la_LIBADD =
--am_rocket_silo_la_OBJECTS = rocket_silo.lo
-+am_rocket_silo_la_OBJECTS = rocket_silo.lo ../src/libsiloh5.la
- rocket_silo_la_OBJECTS = $(am_rocket_silo_la_OBJECTS)
- rocket_silo_la_LINK = $(LIBTOOL) --tag=CXX $(AM_LIBTOOLFLAGS) \
- $(LIBTOOLFLAGS) --mode=link $(CXXLD) $(AM_CXXFLAGS) \
diff --git a/silo-4.10.2-skip-test.patch b/skip-test.patch
index e93a412f57c0..27b77b829ede 100644
--- a/silo-4.10.2-skip-test.patch
+++ b/skip-test.patch
@@ -1,5 +1,5 @@
--- tests/testsuite.at 2016-02-26 12:52:54.249108829 +0100
-+++ tests/testsuite.at.new 2016-02-26 12:58:44.184478494 +0100
++++ tests/testsuite.at 2016-02-26 12:58:44.184478494 +0100
@@ -242,7 +242,7 @@
AT_CLEANUP
AT_SETUP(write objects)
@@ -9,8 +9,8 @@
AT_CLEANUP
AT_BANNER(JSON (experimental))
---- src/silo-4.10.2/tests/testsuite.at 2018-07-04 20:07:16.559992474 +0200
-+++ src/silo-4.10.2/tests/testsuite.at.new 2018-07-04 20:07:10.693169683 +0200
+--- tests/testsuite.at 2018-07-04 20:07:16.559992474 +0200
++++ tests/testsuite.at 2018-07-04 20:07:10.693169683 +0200
@@ -183,7 +183,7 @@
AT_CHECK($VALGRIND csg $STARGS,,ignore)
AT_CLEANUP