summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2019-05-10 23:58:42 -0400
committeracxz2019-05-10 23:58:42 -0400
commitcbe27873382a2d7e0696587bcfc557a59c3234ee (patch)
tree5fc2004e09639255fbe1d28e50f3ddb7719f3ad2
parentcf77eaf30fadc26fab6e6de9454ea0884a5870b2 (diff)
downloadaur-cbe27873382a2d7e0696587bcfc557a59c3234ee.tar.gz
Updated to version 3.6.1 and commented out check() due to one test failing
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD51
2 files changed, 33 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7321a290c85c..334f472bc4c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = simbody
pkgdesc = High-performance C++ multibody dynamics/physics library for simulating articulated biomechanical and mechanical systems like vehicles, robots, and the human skeleton.
- pkgver = 3.6
+ pkgver = 3.6.1
pkgrel = 1
url = https://simtk.org/home/simbody
arch = i686
@@ -13,8 +13,8 @@ pkgbase = simbody
optdepends = libxi
optdepends = libxmu
optdepends = doxygen
- source = https://github.com/simbody/simbody/archive/Simbody-3.6.tar.gz
- sha256sums = bafce4b32dda4e174700733da1cd4f5f77f490daa96b92ed64bb881b0a885aa8
+ source = https://github.com/simbody/simbody/archive/Simbody-3.6.1.tar.gz
+ sha256sums = 7716d6ea20b950e71e8535faa4353ac89716c03fd7a445dd802eb6a630796639
pkgname = simbody
diff --git a/PKGBUILD b/PKGBUILD
index 430ba7fa305e..bc55525d43a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
-# Maintainer: Benjamin Chretien <chretien at lirmm dot fr>
+# Previous Maintainer: Benjamin Chretien <chretien at lirmm dot fr>
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=simbody
-pkgver=3.6
+pkgver=3.6.1
pkgrel=1
pkgdesc="High-performance C++ multibody dynamics/physics library for simulating articulated biomechanical and mechanical systems like vehicles, robots, and the human skeleton."
arch=('i686' 'x86_64')
@@ -12,30 +13,38 @@ makedepends=('cmake')
provides=()
conflicts=()
-_dir="${pkgname}-Simbody-${pkgver}"
source=("https://github.com/simbody/${pkgname}/archive/Simbody-${pkgver}.tar.gz")
-sha256sums=('bafce4b32dda4e174700733da1cd4f5f77f490daa96b92ed64bb881b0a885aa8')
+sha256sums=('7716d6ea20b950e71e8535faa4353ac89716c03fd7a445dd802eb6a630796639')
+
+_buildtype="Release"
build() {
- # Create build directory
- mkdir -p ${srcdir}/build && cd ${srcdir}/build
-
- # Build project
- # Note: CMAKE_INSTALL_LIBDIR is used to avoid the
- # "/usr/lib64 exists in filesystem" error
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
- make
-}
-check() {
- cd "${srcdir}/build"
- make test
+ msg "Starting CMake (build type: ${_buildtype})"
+
+ # Create a build directory
+ mkdir -p "${srcdir}/${pkgname}-Simbody-${pkgver}/build"
+ cd "${srcdir}/${pkgname}-Simbody-${pkgver}/build"
+
+ # Build project
+ cmake .. \
+ -DCMAKE_BUILD_TYPE="${_buildtype}" \
+ -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr"
+ #-DCMAKE_INSTALL_LIBDIR=lib
+
+ msg "Building the project"
+ make -j4
}
+#check() {
+# cd "${srcdir}/${pkgname}-Simbody-${pkgver}/build"
+# make test
+#}
+
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+
+ cd "${srcdir}/${pkgname}-Simbody-${pkgver}/build"
+
+ msg "Installing files"
+ make DESTDIR="${pkgdir}/" install
}