summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Ivanov2015-09-15 20:03:05 +0200
committerPeter Ivanov2015-09-15 20:03:05 +0200
commit2d332d25c2f009d75c2a04cd744b07ee1c55d740 (patch)
tree1fccfe8873deeafa39a01ceb5e0c0ffba2ced802
downloadaur-2d332d25c2f009d75c2a04cd744b07ee1c55d740.tar.gz
Initial commit.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
-rwxr-xr-xpre-commit5
-rw-r--r--simcoupe.desktop10
4 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d77d6f16a84
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = simcoupe
+ pkgdesc = The SAM Coupé Emulator
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.simcoupe.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = make
+ depends = sdl
+ depends = libsaasound
+ source = http://www.simcoupe.org/files/SimCoupe-1.0.tar.gz
+ source = simcoupe.desktop
+ md5sums = 2931e93b877af0a383a4db9424c456f8
+ md5sums = bd4dbdecfccb1eb86dfc9a23309bf5b9
+
+pkgname = simcoupe
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b6345cca27a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Peter Ivanov <ivanovp@gmail.com>
+
+pkgname=simcoupe
+pkgver=1.0
+pkgrel=1
+pkgdesc="The SAM Coupé Emulator"
+arch=('i686' 'x86_64')
+url="http://www.simcoupe.org/"
+license=('GPL')
+depends=('sdl' 'libsaasound')
+makedepends=('make')
+source=("http://www.simcoupe.org/files/SimCoupe-${pkgver}.tar.gz"
+ "simcoupe.desktop")
+
+build() {
+ cd "$srcdir/SimCoupe/SDL"
+ make
+ convert SimCoupe.bmp simcoupe.png
+}
+
+package() {
+ install -m755 -d $pkgdir/usr/{bin,share/applications,share/pixmaps}
+
+ cd "$srcdir/SimCoupe/SDL"
+
+ install -D -m644 ../../simcoupe.desktop $pkgdir/usr/share/applications
+ install -D -m644 simcoupe.png $pkgdir/usr/share/pixmaps
+ install -D -m755 simcoupe $pkgdir/usr/bin
+}
+
+md5sums=('2931e93b877af0a383a4db9424c456f8'
+ 'bd4dbdecfccb1eb86dfc9a23309bf5b9')
+
+# vim:set sts=2 ts=2 sw=2 et:
diff --git a/pre-commit b/pre-commit
new file mode 100755
index 000000000000..3c02b611e1ef
--- /dev/null
+++ b/pre-commit
@@ -0,0 +1,5 @@
+#!/bin/bash
+
+mksrcinfo
+git add -f .SRCINFO
+exit 0
diff --git a/simcoupe.desktop b/simcoupe.desktop
new file mode 100644
index 000000000000..18d40ff44c3e
--- /dev/null
+++ b/simcoupe.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=SimCoupe
+GenericName=SimCoupe
+Comment=The SAM Coupé Emulator
+Exec=/usr/bin/simcoupe
+Icon=simcoupe
+Terminal=false
+Type=Application
+Categories=Game;Emulator
+StartupNotify=false