summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2018-06-05 00:56:58 +0200
committerNarrat2018-06-05 00:56:58 +0200
commitf153eb1ef59889c842ee66560d37d573ac1f1a15 (patch)
tree5cde5373932a480b30dd1151819850561de3f1d0
parent3c92232b8ba1315e4f3ad1feb928daf8e9e47a9f (diff)
downloadaur-simdock-git.tar.gz
update deps
although upstream states wxgtk3, namcap complained about missing wxgtk2
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
-rw-r--r--simdock.install13
3 files changed, 18 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab22cd61f24f..9b1f4cf31f7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = simdock-git
- pkgdesc = Fast and customizable dockbar.
- pkgver = 72.20fec28
+ pkgdesc = Fast and customizable dockbar
+ pkgver = 1.5.2.r3.g383e9c7
pkgrel = 1
url = https://github.com/onli/simdock
- install = simdock.install
arch = i686
arch = x86_64
- license = GPL
- depends = wxgtk2.8
+ license = GPL2
+ depends = wxgtk3
depends = libwnck
+ depends = xcb-util-wm
depends = gconf
+ depends = desktop-file-utils
provides = simdock
conflicts = simdock
- source = git://github.com/onli/simdock.git
+ source = git+https://github.com/onli/simdock.git
md5sums = SKIP
pkgname = simdock-git
diff --git a/PKGBUILD b/PKGBUILD
index 894329453a68..a35bda000195 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,32 @@
# Contributor: sickhate <sickhate@tux-linux.net>
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=simdock-git
-pkgver=72.20fec28
+_repo=simdock
+pkgver=1.5.2.r3.g383e9c7
pkgrel=1
-pkgdesc="Fast and customizable dockbar."
+pkgdesc="Fast and customizable dockbar"
arch=('i686' 'x86_64')
url="https://github.com/onli/simdock"
-license=('GPL')
-depends=('wxgtk2.8' 'libwnck' 'gconf')
+license=('GPL2')
+depends=('wxgtk3' 'libwnck' 'xcb-util-wm' 'gconf' 'desktop-file-utils')
provides=('simdock')
conflicts=('simdock')
-install=simdock.install
-source=("git://github.com/onli/simdock.git")
-_repo=simdock
+source=("git+https://github.com/onli/simdock.git")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/${_repo}"
- printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
-prepare() {
- cd "$srcdir/${_repo}"
- sed -i 's+wx-config+wx-config-2.8+' Makefile
+ cd "${_repo}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/${_repo}"
+ cd "${_repo}"
make
}
package() {
- cd "$srcdir/${_repo}"
+ cd "${_repo}"
make DESTDIR="$pkgdir" install
rm -rf $pkgdir/usr/local
}
diff --git a/simdock.install b/simdock.install
deleted file mode 100644
index bab92327c130..000000000000
--- a/simdock.install
+++ /dev/null
@@ -1,13 +0,0 @@
-pkgname=simdock
-
-post_install() {
- update-desktop-database -q
-}
-
-post_upgrade() {
- post_install "$1"
-}
-
-post_remove() {
- update-desktop-database -q
-}